{"answers":{"affected":"2 open source packages ship an affected version, including phpmailer/phpmailer. It affects 1 product.","exploited":"There is no known exploitation of CVE-2006-5734 in the wild and no public exploit code.","fix":"Upgrade phpmailer/phpmailer to 5.2.0 or later.","what":"CVE-2006-5734 is a high-severity vulnerability in n/a, published on 6 Nov 2006. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2006-5734 and fix it if it is affected.\n\nWhat it is: CVE-2006-5734 is a high-severity vulnerability in n/a, published on 6 Nov 2006. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2006-5734 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- phpmailer/phpmailer (Packagist): affected all versions; fixed in 5.2.0\n- phpmailer/phpmailer (Packagist): affected all versions; fixed in 5.2.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2006-5734/ (Markdown: https://insights.sbomify.com/CVE-2006-5734/index.md)","id":"CVE-2006-5734","markdown":"https://insights.sbomify.com/CVE-2006-5734/index.md","name":"CVE-2006-5734","record":{"aliases":["GHSA-8jc3-5p29-qgjx"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"ATutor LMS","requires_auth":"none","summary":"Remote attackers can execute arbitrary PHP code in ATutor via remote file inclusion in multiple parameters.","user_interaction":"not_required","vuln_class":"file_upload"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"atutor","vendor":"adaptive_technology_resource_centre"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"AV:N/AC:L/Au:N/C:P/I:P/A:P","version":"2.0"},"cwes":[],"description":"Multiple PHP remote file inclusion vulnerabilities in ATutor 1.5.3.2 allow remote attackers to execute arbitrary PHP code via a URL in the (1) section parameter in (a) documentation/common/frame_toc.php and (b) documentation/common/search.php, the (2) req_lang parameter in documentation/common/search.php and (c) documentation/common/vitals.inc.php, the (3) row[dir_name] parameter in (d) include/classes/module/module.class.php, and the (4) lang_path parameter in (e) include/classes/phpmailer/class.phpmailer.php.  NOTE: the print.php vector is already covered by CVE-2005-3404.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"PHPMailer Local file inclusion","id":"CVE-2006-5734","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"file_upload","year":"2006"},"n_packages":2,"n_references":4,"next":{"headline":"Path traversal in n/a","id":"CVE-2006-5735"},"packages":[{"ecosystem":"Packagist","fixed":["5.2.0"],"introduced":["0"],"last_affected":[],"package":"phpmailer/phpmailer","purl":null,"source":"GHSA-8jc3-5p29-qgjx"},{"ecosystem":"Packagist","fixed":["5.2.0"],"introduced":["0"],"last_affected":[],"package":"phpmailer/phpmailer","purl":"pkg:composer/phpmailer/phpmailer","source":"GHSA-8jc3-5p29-qgjx"}],"prev":{"headline":"Path traversal in n/a","id":"CVE-2006-5733"},"products":["n/a"],"published":"2006-11-06","related":[{"cvss_score":7.5,"headline":"SQL injection in n/a","id":"CVE-2007-0381","kev_date_added":null,"published":"2007-01-19"},{"cvss_score":7.5,"headline":"SQL injection in n/a","id":"CVE-2006-3662","kev_date_added":null,"published":"2006-07-17"},{"cvss_score":7.5,"headline":"SQL injection in n/a","id":"CVE-2005-4155","kev_date_added":null,"published":"2005-12-11"},{"cvss_score":7.5,"headline":"Path traversal in n/a","id":"CVE-2005-3404","kev_date_added":null,"published":"2005-11-01"},{"cvss_score":7.5,"headline":"SQL injection in n/a","id":"CVE-2005-2954","kev_date_added":null,"published":"2005-09-16"},{"cvss_score":6.5,"headline":"SQL injection in n/a","id":"CVE-2006-3996","kev_date_added":null,"published":"2006-08-05"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-07","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary PHP code in ATutor via remote file inclusion in multiple parameters.","url":"https://insights.sbomify.com/CVE-2006-5734/"}