# CVE-2006-5734: PHPMailer Local file inclusion

> Remote attackers can execute arbitrary PHP code in ATutor via remote file inclusion in multiple parameters.

- **Severity:** High 7.5 (`AV:N/AC:L/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Nov 2006
- **Updated:** 7 Aug 2024
- **Also known as:** GHSA-8jc3-5p29-qgjx

## What is CVE-2006-5734?

CVE-2006-5734 is a high-severity vulnerability in n/a, published on 6 Nov 2006. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Multiple PHP remote file inclusion vulnerabilities in ATutor 1.5.3.2 allow remote attackers to execute arbitrary PHP code via a URL in the (1) section parameter in (a) documentation/common/frame_toc.php and (b) documentation/common/search.php, the (2) req_lang parameter in documentation/common/search.php and (c) documentation/common/vitals.inc.php, the (3) row[dir_name] parameter in (d) include/classes/module/module.class.php, and the (4) lang_path parameter in (e) include/classes/phpmailer/class.phpmailer.php.  NOTE: the print.php vector is already covered by CVE-2005-3404.

## Which versions are affected by CVE-2006-5734?

2 open source packages ship an affected version, including phpmailer/phpmailer. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpmailer/phpmailer` | Packagist | All versions | 5.2.0 |
| `phpmailer/phpmailer` | Packagist | All versions | 5.2.0 |

Products: Adaptive Technology Resource Centre Atutor.

## How do I fix CVE-2006-5734?

Upgrade phpmailer/phpmailer to 5.2.0 or later.

## Is CVE-2006-5734 being exploited?

There is no known exploitation of CVE-2006-5734 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2007-0381](https://insights.sbomify.com/CVE-2007-0381/): SQL injection in n/a (high 7.5)
- [CVE-2006-3662](https://insights.sbomify.com/CVE-2006-3662/): SQL injection in n/a (high 7.5)
- [CVE-2005-4155](https://insights.sbomify.com/CVE-2005-4155/): SQL injection in n/a (high 7.5)
- [CVE-2005-3404](https://insights.sbomify.com/CVE-2005-3404/): Path traversal in n/a (high 7.5)
- [CVE-2005-2954](https://insights.sbomify.com/CVE-2005-2954/): SQL injection in n/a (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2006-5734 and fix it if it is affected.

What it is: CVE-2006-5734 is a high-severity vulnerability in n/a, published on 6 Nov 2006. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2006-5734 in the wild and no public exploit code.

Affected packages and fixed versions:
- phpmailer/phpmailer (Packagist): affected all versions; fixed in 5.2.0
- phpmailer/phpmailer (Packagist): affected all versions; fixed in 5.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2006-5734/ (Markdown: https://insights.sbomify.com/CVE-2006-5734/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2006-5734
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2006-5734
- OSV: https://osv.dev/vulnerability/CVE-2006-5734

---
From sbomify Insights: https://insights.sbomify.com/CVE-2006-5734/
Summaries are generated and may contain mistakes; the official description above is the record.
