# CVE-2006-5878: Edgewall Trac Cross-site request forgery (CSRF) vulnerability

> Remote attackers can perform unauthorized actions as other users in Trac via CSRF, requiring user interaction to exploit.

- **Severity:** High 7.5 (`AV:N/AC:L/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 Nov 2006
- **Updated:** 7 Aug 2024
- **Also known as:** CVE-2006-5848, DEBIAN-CVE-2006-5878, DSA-1209, GHSA-2q26-r8c4-jfx5, PYSEC-2006-3

## What is CVE-2006-5878?

CVE-2006-5878 is a high-severity vulnerability in n/a, published on 14 Nov 2006. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Cross-site request forgery (CSRF) vulnerability in Edgewall Trac 0.10 and earlier allows remote attackers to perform unauthorized actions as other users via unknown vectors.

## Which versions are affected by CVE-2006-5878?

3 open source packages ship an affected version, including trac. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `trac` | PyPI | All versions | 0.10.1 |
| `trac` | PyPI | All versions | 0.10.1 |
| `trac` | PyPI | All versions | 0.11 |

Products: Edgewall Software Trac.

## How do I fix CVE-2006-5878?

Upgrade trac to a fixed version for your release line: 0.10.1 or 0.11.

## Is CVE-2006-5878 being exploited?

There is no known exploitation of CVE-2006-5878 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2007-1406](https://insights.sbomify.com/CVE-2007-1406/): Trac missing Content-Disposition HTTP header (critical 10.0)
- [CVE-2005-4065](https://insights.sbomify.com/CVE-2005-4065/): SQL injection in n/a (high 7.5)
- [CVE-2005-3980](https://insights.sbomify.com/CVE-2005-3980/): SQL injection in n/a (high 7.5)
- [CVE-2006-3695](https://insights.sbomify.com/CVE-2006-3695/): Trac reStructuredText breach of privacy and denial of service vulnerability (medium 6.8)
- [CVE-2005-2147](https://insights.sbomify.com/CVE-2005-2147/): Path traversal in n/a (medium 6.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2006-5878 and fix it if it is affected.

What it is: CVE-2006-5878 is a high-severity vulnerability in n/a, published on 14 Nov 2006. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2006-5878 in the wild and no public exploit code.

Affected packages and fixed versions:
- trac (PyPI): affected all versions; fixed in 0.10.1
- trac (PyPI): affected all versions; fixed in 0.10.1
- trac (PyPI): affected all versions; fixed in 0.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2006-5878/ (Markdown: https://insights.sbomify.com/CVE-2006-5878/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2006-5878
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2006-5878
- OSV: https://osv.dev/vulnerability/CVE-2006-5878

---
From sbomify Insights: https://insights.sbomify.com/CVE-2006-5878/
Summaries are generated and may contain mistakes; the official description above is the record.
