CVE-2006-6969 Jetty Uses Predictable Session Identifiers
Remote attackers can guess predictable session IDs to bypass authentication and potentially perform CSRF attacks on Jetty servers.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2006-6969?
CVE-2006-6969 is a medium-severity vulnerability in n/a, published on 7 Feb 2007. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Jetty before 4.2.27, 5.1 before 5.1.12, 6.0 before 6.0.2, and 6.1 before 6.1.0pre3 generates predictable session identifiers using java.util.random, which makes it easier for remote attackers to guess a session identifier through brute force attacks, bypass authentication requirements, and possibly conduct cross-site request forgery attacks.
Which versions are affected by CVE-2006-6969?
8 open source packages ship an affected version, including org.eclipse.jetty:jetty-server. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.eclipse.jetty:jetty-server Maven | All versions | 4.2.27 |
org.eclipse.jetty:jetty-server Maven | All versions | 4.2.27 |
org.eclipse.jetty:jetty-server Maven | From 5.1.0 | 5.1.12 |
org.eclipse.jetty:jetty-server Maven | From 5.1.0 | 5.1.12 |
org.eclipse.jetty:jetty-server Maven | From 6.0.0 | 6.0.2 |
org.eclipse.jetty:jetty-server Maven | From 6.0.0 | 6.0.2 |
2 more packages
org.eclipse.jetty:jetty-server Maven | From 6.1.0pre1 | 6.1.0pre3 |
org.eclipse.jetty:jetty-server Maven | From 6.1.0pre1 | 6.1.0pre3 |
Products include Jetty Jetty Http Server.
How do I fix CVE-2006-6969?
Upgrade org.eclipse.jetty:jetty-server to a fixed version for your release line: 4.2.27, 5.1.12, 6.0.2 or 6.1.0pre3.
Is CVE-2006-6969 being exploited?
There is no known exploitation of CVE-2006-6969 in the wild and no public exploit code.
Other vulnerabilities in n/a
Sources
Also known as GHSA-jg2x-r643-w2ch.