{"answers":{"affected":"8 open source packages ship an affected version, including org.eclipse.jetty:jetty-server. It affects 1 product.","exploited":"There is no known exploitation of CVE-2006-6969 in the wild and no public exploit code.","fix":"Upgrade org.eclipse.jetty:jetty-server to a fixed version for your release line: 4.2.27, 5.1.12, 6.0.2 or 6.1.0pre3.","what":"CVE-2006-6969 is a medium-severity vulnerability in n/a, published on 7 Feb 2007. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2006-6969 and fix it if it is affected.\n\nWhat it is: CVE-2006-6969 is a medium-severity vulnerability in n/a, published on 7 Feb 2007. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2006-6969 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.eclipse.jetty:jetty-server (Maven): affected all versions; fixed in 4.2.27\n- org.eclipse.jetty:jetty-server (Maven): affected all versions; fixed in 4.2.27\n- org.eclipse.jetty:jetty-server (Maven): affected from 5.1.0; fixed in 5.1.12\n- org.eclipse.jetty:jetty-server (Maven): affected from 5.1.0; fixed in 5.1.12\n- org.eclipse.jetty:jetty-server (Maven): affected from 6.0.0; fixed in 6.0.2\n- org.eclipse.jetty:jetty-server (Maven): affected from 6.0.0; fixed in 6.0.2\n- org.eclipse.jetty:jetty-server (Maven): affected from 6.1.0pre1; fixed in 6.1.0pre3\n- org.eclipse.jetty:jetty-server (Maven): affected from 6.1.0pre1; fixed in 6.1.0pre3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2006-6969/ (Markdown: https://insights.sbomify.com/CVE-2006-6969/index.md)","id":"CVE-2006-6969","markdown":"https://insights.sbomify.com/CVE-2006-6969/index.md","name":"CVE-2006-6969","record":{"aliases":["GHSA-jg2x-r643-w2ch"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["security_bypass","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Jetty web server","requires_auth":"none","summary":"Remote attackers can guess predictable session IDs to bypass authentication and potentially perform CSRF attacks on Jetty servers.","user_interaction":"not_required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"jetty_http_server","vendor":"jetty"}],"cvss":{"score":6.8,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:P/I:P/A:P","version":"2.0"},"cwes":[],"description":"Jetty before 4.2.27, 5.1 before 5.1.12, 6.0 before 6.0.2, and 6.1 before 6.1.0pre3 generates predictable session identifiers using java.util.random, which makes it easier for remote attackers to guess a session identifier through brute force attacks, bypass authentication requirements, and possibly conduct cross-site request forgery attacks.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Jetty Uses Predictable Session Identifiers","id":"CVE-2006-6969","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"weak_cryptography","year":"2006"},"n_packages":8,"n_references":8,"next":{"headline":"Security feature bypass in n/a","id":"CVE-2006-6970"},"packages":[{"ecosystem":"Maven","fixed":["4.2.27"],"introduced":["0"],"last_affected":[],"package":"org.eclipse.jetty:jetty-server","purl":null,"source":"GHSA-jg2x-r643-w2ch"},{"ecosystem":"Maven","fixed":["4.2.27"],"introduced":["0"],"last_affected":[],"package":"org.eclipse.jetty:jetty-server","purl":"pkg:maven/org.eclipse.jetty/jetty-server","source":"GHSA-jg2x-r643-w2ch"},{"ecosystem":"Maven","fixed":["5.1.12"],"introduced":["5.1.0"],"last_affected":[],"package":"org.eclipse.jetty:jetty-server","purl":null,"source":"GHSA-jg2x-r643-w2ch"},{"ecosystem":"Maven","fixed":["5.1.12"],"introduced":["5.1.0"],"last_affected":[],"package":"org.eclipse.jetty:jetty-server","purl":"pkg:maven/org.eclipse.jetty/jetty-server","source":"GHSA-jg2x-r643-w2ch"},{"ecosystem":"Maven","fixed":["6.0.2"],"introduced":["6.0.0"],"last_affected":[],"package":"org.eclipse.jetty:jetty-server","purl":null,"source":"GHSA-jg2x-r643-w2ch"},{"ecosystem":"Maven","fixed":["6.0.2"],"introduced":["6.0.0"],"last_affected":[],"package":"org.eclipse.jetty:jetty-server","purl":"pkg:maven/org.eclipse.jetty/jetty-server","source":"GHSA-jg2x-r643-w2ch"},{"ecosystem":"Maven","fixed":["6.1.0pre3"],"introduced":["6.1.0pre1"],"last_affected":[],"package":"org.eclipse.jetty:jetty-server","purl":null,"source":"GHSA-jg2x-r643-w2ch"},{"ecosystem":"Maven","fixed":["6.1.0pre3"],"introduced":["6.1.0pre1"],"last_affected":[],"package":"org.eclipse.jetty:jetty-server","purl":"pkg:maven/org.eclipse.jetty/jetty-server","source":"GHSA-jg2x-r643-w2ch"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2006-6968"},"products":["n/a"],"published":"2007-02-07","related":[{"cvss_score":5,"headline":"Jetty HTTP Server Denial of Service vulnerability","id":"CVE-2004-2381","kev_date_added":null,"published":"2005-08-16"},{"cvss_score":5,"headline":"Path traversal in n/a","id":"CVE-2002-1178","kev_date_added":null,"published":"2004-09-01"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-07","vendors":["n/a"]},"summary":"Remote attackers can guess predictable session IDs to bypass authentication and potentially perform CSRF attacks on Jetty servers.","url":"https://insights.sbomify.com/CVE-2006-6969/"}