CVE-2006-7196 Cross-site scripting in Apache Tomcat
Remote attackers can inject arbitrary web script via the time parameter in the Tomcat calendar example, requiring user interaction to execute.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2006-7196?
CVE-2006-7196 is a medium-severity cross-site scripting vulnerability in Apache Tomcat, published on 9 May 2007. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Cross-site scripting (XSS) vulnerability in the calendar application example in Apache Tomcat 4.0.0 through 4.0.6, 4.1.0 through 4.1.31, 5.0.0 through 5.0.30, and 5.5.0 through 5.5.15 allows remote attackers to inject arbitrary web script or HTML via the time parameter to cal2.jsp and possibly unspecified other vectors. NOTE: this may be related to CVE-2006-0254.1.
Weakness: CWE-79
Which versions are affected by CVE-2006-7196?
8 open source packages ship an affected version, including org.apache.tomcat:tomcat. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.tomcat:tomcat Maven | From 4.0.0 | 4.0.7 |
org.apache.tomcat:tomcat Maven | From 4.0.0 | 4.0.7 |
org.apache.tomcat:tomcat Maven | From 4.1.0 | 4.1.32 |
org.apache.tomcat:tomcat Maven | From 4.1.0 | 4.1.32 |
org.apache.tomcat:tomcat Maven | From 5.0.0 | 5.0.31 |
org.apache.tomcat:tomcat Maven | From 5.0.0 | 5.0.31 |
2 more packages
org.apache.tomcat:tomcat Maven | From 5.5.0 | 5.5.16 |
org.apache.tomcat:tomcat Maven | From 5.5.0 | 5.5.16 |
Products include Apache Tomcat.
How do I fix CVE-2006-7196?
Upgrade org.apache.tomcat:tomcat to a fixed version for your release line: 4.0.7, 4.1.32, 5.0.31 or 5.5.16.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2006-7196 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2006-7196 exists.
Public exploit code: 1 Exploit-DB entry.
Other vulnerabilities in Apache Tomcat
Sources
Also known as GHSA-pm78-wxxf-fw98.