# CVE-2006-7196: Cross-site scripting in Apache Tomcat

> Remote attackers can inject arbitrary web script via the time parameter in the Tomcat calendar example, requiring user interaction to execute.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 May 2007
- **Updated:** 7 Aug 2024
- **Also known as:** GHSA-pm78-wxxf-fw98

## What is CVE-2006-7196?

CVE-2006-7196 is a medium-severity cross-site scripting vulnerability in Apache Tomcat, published on 9 May 2007. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cross-site scripting (XSS) vulnerability in the calendar application example in Apache Tomcat 4.0.0 through 4.0.6, 4.1.0 through 4.1.31, 5.0.0 through 5.0.30, and 5.5.0 through 5.5.15 allows remote attackers to inject arbitrary web script or HTML via the time parameter to cal2.jsp and possibly unspecified other vectors.  NOTE: this may be related to CVE-2006-0254.1.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2006-7196?

8 open source packages ship an affected version, including org.apache.tomcat:tomcat. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.tomcat:tomcat` | Maven | From 4.0.0 | 4.0.7 |
| `org.apache.tomcat:tomcat` | Maven | From 4.0.0 | 4.0.7 |
| `org.apache.tomcat:tomcat` | Maven | From 4.1.0 | 4.1.32 |
| `org.apache.tomcat:tomcat` | Maven | From 4.1.0 | 4.1.32 |
| `org.apache.tomcat:tomcat` | Maven | From 5.0.0 | 5.0.31 |
| `org.apache.tomcat:tomcat` | Maven | From 5.0.0 | 5.0.31 |
| `org.apache.tomcat:tomcat` | Maven | From 5.5.0 | 5.5.16 |
| `org.apache.tomcat:tomcat` | Maven | From 5.5.0 | 5.5.16 |

Products: Apache Tomcat.

## How do I fix CVE-2006-7196?

Upgrade org.apache.tomcat:tomcat to a fixed version for your release line: 4.0.7, 4.1.32, 5.0.31 or 5.5.16.

## Is CVE-2006-7196 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2006-7196 exists.

Public exploit code:

- Apache Tomcat 5.5.15 - cal2.jsp Cross-Site Scripting (exploitdb)

## Other vulnerabilities in Apache Tomcat

- [CVE-2025-24813](https://insights.sbomify.com/CVE-2025-24813/): Apache Tomcat Path Equivalence (critical 10.0, exploited in the wild)
- [CVE-2016-8735](https://insights.sbomify.com/CVE-2016-8735/): Apache Tomcat Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2017-12617](https://insights.sbomify.com/CVE-2017-12617/): Apache Tomcat Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2017-12615](https://insights.sbomify.com/CVE-2017-12615/): Apache Tomcat on Windows Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2026-34486](https://insights.sbomify.com/CVE-2026-34486/): Apache Tomcat Missing Encryption of Sensitive Data (high 7.5, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2006-7196 and fix it if it is affected.

What it is: CVE-2006-7196 is a medium-severity cross-site scripting vulnerability in Apache Tomcat, published on 9 May 2007. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2006-7196 exists.

Affected packages and fixed versions:
- org.apache.tomcat:tomcat (Maven): affected from 4.0.0; fixed in 4.0.7
- org.apache.tomcat:tomcat (Maven): affected from 4.0.0; fixed in 4.0.7
- org.apache.tomcat:tomcat (Maven): affected from 4.1.0; fixed in 4.1.32
- org.apache.tomcat:tomcat (Maven): affected from 4.1.0; fixed in 4.1.32
- org.apache.tomcat:tomcat (Maven): affected from 5.0.0; fixed in 5.0.31
- org.apache.tomcat:tomcat (Maven): affected from 5.0.0; fixed in 5.0.31
- org.apache.tomcat:tomcat (Maven): affected from 5.5.0; fixed in 5.5.16
- org.apache.tomcat:tomcat (Maven): affected from 5.5.0; fixed in 5.5.16

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2006-7196/ (Markdown: https://insights.sbomify.com/CVE-2006-7196/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2006-7196
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2006-7196
- OSV: https://osv.dev/vulnerability/CVE-2006-7196

---
From sbomify Insights: https://insights.sbomify.com/CVE-2006-7196/
Summaries are generated and may contain mistakes; the official description above is the record.
