# CVE-2006-7217: Apache Derby SQL Injection

> Authenticated users can bypass schema privilege checks to drop arbitrary schemas in Apache Derby when SQL authorization is enabled.

- **Severity:** Medium 4.0 (`AV:N/AC:L/Au:S/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Jul 2007
- **Updated:** 7 Aug 2024
- **Also known as:** GHSA-v7cq-pq7v-mh5v

## What is CVE-2006-7217?

CVE-2006-7217 is a medium-severity missing authorization vulnerability in n/a, published on 5 Jul 2007. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Apache Derby before 10.2.1.6 does not determine schema privilege requirements during the DropSchemaNode bind phase, which allows remote authenticated users to execute arbitrary drop schema statements in SQL authorization mode.

## Which versions are affected by CVE-2006-7217?

2 open source packages ship an affected version, including org.apache.derby:derby. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.derby:derby` | Maven | All versions | 10.2.1.6 |
| `org.apache.derby:derby` | Maven | All versions | 10.2.1.6 |

Products: Apache Derby.

## How do I fix CVE-2006-7217?

Upgrade org.apache.derby:derby to 10.2.1.6 or later.

## Is CVE-2006-7217 being exploited?

There is no known exploitation of CVE-2006-7217 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2022-46337](https://insights.sbomify.com/CVE-2022-46337/): Apache Derby: LDAP injection vulnerability in authenticator (critical 9.8)
- [CVE-2015-1832](https://insights.sbomify.com/CVE-2015-1832/): Improper Restriction of XML External Entity Reference in Apace Derby (critical 9.1)
- [CVE-2010-2232](https://insights.sbomify.com/CVE-2010-2232/): Improper Access Control in Apache Derby (high 7.5)
- [CVE-2018-1313](https://insights.sbomify.com/CVE-2018-1313/): Improper Access Control in Apache Derby (medium 5.3)
- [CVE-2005-4849](https://insights.sbomify.com/CVE-2005-4849/): Apache Derby exposes user and password attributes (medium 5.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2006-7217 and fix it if it is affected.

What it is: CVE-2006-7217 is a medium-severity missing authorization vulnerability in n/a, published on 5 Jul 2007. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2006-7217 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.derby:derby (Maven): affected all versions; fixed in 10.2.1.6
- org.apache.derby:derby (Maven): affected all versions; fixed in 10.2.1.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2006-7217/ (Markdown: https://insights.sbomify.com/CVE-2006-7217/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2006-7217
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2006-7217
- OSV: https://osv.dev/vulnerability/CVE-2006-7217

---
From sbomify Insights: https://insights.sbomify.com/CVE-2006-7217/
Summaries are generated and may contain mistakes; the official description above is the record.
