# CVE-2007-0185: Direct Web Remoting vulnerable to Denial of Service

> Attackers can cause denial of service via memory exhaustion by sending a large number of batch calls to the DWR library.

- **Severity:** Medium 5.0 (`AV:N/AC:L/Au:N/C:N/I:N/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Jan 2007
- **Updated:** 7 Aug 2024
- **Also known as:** GHSA-hg5p-233h-c7fh

## What is CVE-2007-0185?

CVE-2007-0185 is a medium-severity denial of service vulnerability in n/a, published on 11 Jan 2007. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Getahead Direct Web Remoting (DWR) before 1.1.4 allows attackers to cause a denial of service (memory exhaustion and servlet outage) via unknown vectors related to a large number of calls in a batch.

## Which versions are affected by CVE-2007-0185?

2 open source packages ship an affected version, including org.directwebremoting:dwr. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.directwebremoting:dwr` | Maven | All versions | 1.1.4 |
| `org.directwebremoting:dwr` | Maven | All versions | 1.1.4 |

Products: Getahead Direct Web Remoting.

## How do I fix CVE-2007-0185?

Upgrade org.directwebremoting:dwr to 1.1.4 or later.

## Is CVE-2007-0185 being exploited?

There is no known exploitation of CVE-2007-0185 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2006-6916](https://insights.sbomify.com/CVE-2006-6916/): Denial of service in n/a (high 7.5)
- [CVE-2007-0184](https://insights.sbomify.com/CVE-2007-0184/): Incorrect Authorization in Getahead Direct Web Remoting (high 7.5)
- [CVE-2007-2377](https://insights.sbomify.com/CVE-2007-2377/): Information disclosure in n/a (medium 5.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2007-0185 and fix it if it is affected.

What it is: CVE-2007-0185 is a medium-severity denial of service vulnerability in n/a, published on 11 Jan 2007. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2007-0185 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.directwebremoting:dwr (Maven): affected all versions; fixed in 1.1.4
- org.directwebremoting:dwr (Maven): affected all versions; fixed in 1.1.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2007-0185/ (Markdown: https://insights.sbomify.com/CVE-2007-0185/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2007-0185
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2007-0185
- OSV: https://osv.dev/vulnerability/CVE-2007-0185

---
From sbomify Insights: https://insights.sbomify.com/CVE-2007-0185/
Summaries are generated and may contain mistakes; the official description above is the record.
