# CVE-2007-0404: Django Arbitrary Code Execution

> Attackers can execute arbitrary commands via shell metacharacters in .po or .mo files processed by Django's compile-messages script.

- **Severity:** High 7.5 (`AV:N/AC:L/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Not stated
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 23 Jan 2007
- **Updated:** 7 Aug 2024
- **Also known as:** DEBIAN-CVE-2007-0404, GHSA-qc99-g3wm-hgxr, PYSEC-2026-630

## What is CVE-2007-0404?

CVE-2007-0404 is a high-severity command injection vulnerability in n/a, published on 23 Jan 2007. 

### Official description

bin/compile-messages.py in Django 0.95 does not quote argument strings before invoking the msgfmt program through the os.system function, which allows attackers to execute arbitrary commands via shell metacharacters in a (1) .po or (2) .mo file.

## Which versions are affected by CVE-2007-0404?

3 open source packages ship an affected version, including django and Django. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `django` | PyPI | From 0.95 | 1.0 |
| `django` | PyPI | From 0.95 | 1.0 |
| `Django` | PyPI | From 0.95 | 1.0 |

Products: Django Project Django.

## How do I fix CVE-2007-0404?

Upgrade django to 1.0 or later.

## Is CVE-2007-0404 being exploited?

There is no known exploitation of CVE-2007-0404 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2007-5828](https://insights.sbomify.com/CVE-2007-5828/): Cross-site request forgery in n/a (medium 6.8)
- [CVE-2007-0405](https://insights.sbomify.com/CVE-2007-0405/): Django Improper Access Control (medium 6.5)
- [CVE-2009-2659](https://insights.sbomify.com/CVE-2009-2659/): Django Admin Media Handler Vulnerable to Directory Traversal (medium 5.0)
- [CVE-2008-2302](https://insights.sbomify.com/CVE-2008-2302/): Django Cross-site scripting (XSS) vulnerability (medium 4.3)
- [CVE-2007-5712](https://insights.sbomify.com/CVE-2007-5712/): Django vulnerable to Denial of Service via i18n middleware component (low 2.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2007-0404 and fix it if it is affected.

What it is: CVE-2007-0404 is a high-severity command injection vulnerability in n/a, published on 23 Jan 2007. 
Exploitation: There is no known exploitation of CVE-2007-0404 in the wild and no public exploit code.

Affected packages and fixed versions:
- django (PyPI): affected from 0.95; fixed in 1.0
- django (PyPI): affected from 0.95; fixed in 1.0
- Django (PyPI): affected from 0.95; fixed in 1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2007-0404/ (Markdown: https://insights.sbomify.com/CVE-2007-0404/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2007-0404
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2007-0404
- OSV: https://osv.dev/vulnerability/CVE-2007-0404

---
From sbomify Insights: https://insights.sbomify.com/CVE-2007-0404/
Summaries are generated and may contain mistakes; the official description above is the record.
