# CVE-2007-0405: Django Improper Access Control

> Remote authenticated users can gain another user's privileges due to improper caching in Django's AuthenticationMiddleware.

- **Severity:** Medium 6.5 (`AV:N/AC:L/Au:S/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Jan 2007
- **Updated:** 7 Aug 2024
- **Also known as:** DEBIAN-CVE-2007-0405, GHSA-mwv2-398h-v489, PYSEC-2026-629

## What is CVE-2007-0405?

CVE-2007-0405 is a medium-severity vulnerability in n/a, published on 23 Jan 2007. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

The LazyUser class in the AuthenticationMiddleware for Django 0.95 does not properly cache the user name across requests, which allows remote authenticated users to gain the privileges of a different user.

## Which versions are affected by CVE-2007-0405?

3 open source packages ship an affected version, including django and Django. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `django` | PyPI | From 0.95 | 1.0 |
| `django` | PyPI | From 0.95 | 1.0 |
| `Django` | PyPI | From 0.95 | 1.0 |

Products: Django Project Django.

## How do I fix CVE-2007-0405?

Upgrade django to 1.0 or later.

## Is CVE-2007-0405 being exploited?

There is no known exploitation of CVE-2007-0405 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2007-0404](https://insights.sbomify.com/CVE-2007-0404/): Django Arbitrary Code Execution (high 7.5)
- [CVE-2007-5828](https://insights.sbomify.com/CVE-2007-5828/): Cross-site request forgery in n/a (medium 6.8)
- [CVE-2009-2659](https://insights.sbomify.com/CVE-2009-2659/): Django Admin Media Handler Vulnerable to Directory Traversal (medium 5.0)
- [CVE-2008-2302](https://insights.sbomify.com/CVE-2008-2302/): Django Cross-site scripting (XSS) vulnerability (medium 4.3)
- [CVE-2007-5712](https://insights.sbomify.com/CVE-2007-5712/): Django vulnerable to Denial of Service via i18n middleware component (low 2.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2007-0405 and fix it if it is affected.

What it is: CVE-2007-0405 is a medium-severity vulnerability in n/a, published on 23 Jan 2007. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2007-0405 in the wild and no public exploit code.

Affected packages and fixed versions:
- django (PyPI): affected from 0.95; fixed in 1.0
- django (PyPI): affected from 0.95; fixed in 1.0
- Django (PyPI): affected from 0.95; fixed in 1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2007-0405/ (Markdown: https://insights.sbomify.com/CVE-2007-0405/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2007-0405
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2007-0405
- OSV: https://osv.dev/vulnerability/CVE-2007-0405

---
From sbomify Insights: https://insights.sbomify.com/CVE-2007-0405/
Summaries are generated and may contain mistakes; the official description above is the record.
