CVE-2007-0450 Apache Tomcat Directory Traversal
Remote attackers can read arbitrary files via directory traversal in Apache Tomcat when using specific proxy modules with mixed slash separators.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2007-0450?
CVE-2007-0450 is a medium-severity path traversal vulnerability in Apache Http Server, published on 16 Mar 2007. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Directory traversal vulnerability in Apache HTTP Server and Tomcat 5.x before 5.5.22 and 6.x before 6.0.10, when using certain proxy modules (mod_proxy, mod_rewrite, mod_jk), allows remote attackers to read arbitrary files via a .. (dot dot) sequence with combinations of (1) "/" (slash), (2) "\" (backslash), and (3) URL-encoded backslash (%5C) characters in the URL, which are valid separators in Tomcat but not in Apache.
Weakness: CWE-22
Which versions are affected by CVE-2007-0450?
4 open source packages ship an affected version, including org.apache.tomcat:tomcat. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.tomcat:tomcat Maven | From 5.0 | 5.5.22 |
org.apache.tomcat:tomcat Maven | From 5.0 | 5.5.22 |
org.apache.tomcat:tomcat Maven | From 6.0 | 6.0.10 |
org.apache.tomcat:tomcat Maven | From 6.0 | 6.0.10 |
Products include Apache Http Server, Apache Tomcat.
How do I fix CVE-2007-0450?
Upgrade org.apache.tomcat:tomcat to a fixed version for your release line: 5.5.22 or 6.0.10.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2007-0450 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2007-0450 exists.
Public exploit code: 1 Exploit-DB entry.
Other vulnerabilities in Apache Http Server
Sources
Also known as GHSA-4prh-gqw8-rgh5, MINI-6vfq-x5r4-p5gj.