# CVE-2007-0450: Apache Tomcat Directory Traversal

> Remote attackers can read arbitrary files via directory traversal in Apache Tomcat when using specific proxy modules with mixed slash separators.

- **Severity:** Medium 5.0 (`AV:N/AC:L/Au:N/C:P/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Mar 2007
- **Updated:** 7 Aug 2024
- **Also known as:** GHSA-4prh-gqw8-rgh5, MINI-6vfq-x5r4-p5gj

## What is CVE-2007-0450?

CVE-2007-0450 is a medium-severity path traversal vulnerability in Apache Http Server, published on 16 Mar 2007. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Directory traversal vulnerability in Apache HTTP Server and Tomcat 5.x before 5.5.22 and 6.x before 6.0.10, when using certain proxy modules (mod_proxy, mod_rewrite, mod_jk), allows remote attackers to read arbitrary files via a .. (dot dot) sequence with combinations of (1) "/" (slash), (2) "\" (backslash), and (3) URL-encoded backslash (%5C) characters in the URL, which are valid separators in Tomcat but not in Apache.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2007-0450?

4 open source packages ship an affected version, including org.apache.tomcat:tomcat. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.tomcat:tomcat` | Maven | From 5.0 | 5.5.22 |
| `org.apache.tomcat:tomcat` | Maven | From 5.0 | 5.5.22 |
| `org.apache.tomcat:tomcat` | Maven | From 6.0 | 6.0.10 |
| `org.apache.tomcat:tomcat` | Maven | From 6.0 | 6.0.10 |

Products: Apache Http Server, Apache Tomcat.

## How do I fix CVE-2007-0450?

Upgrade org.apache.tomcat:tomcat to a fixed version for your release line: 5.5.22 or 6.0.10.

## Is CVE-2007-0450 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2007-0450 exists.

Public exploit code:

- Apache Tomcat 5.x/6.0.x - Directory Traversal (exploitdb)

## Other vulnerabilities in Apache Http Server

- [CVE-2021-42013](https://insights.sbomify.com/CVE-2021-42013/): Apache HTTP Server Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2024-38475](https://insights.sbomify.com/CVE-2024-38475/): Apache HTTP Server Improper Escaping of Output (critical 9.1, exploited in the wild)
- [CVE-2021-40438](https://insights.sbomify.com/CVE-2021-40438/): Apache HTTP Server-Side Request Forgery (SSRF) (critical 9.0, exploited in the wild)
- [CVE-2019-0211](https://insights.sbomify.com/CVE-2019-0211/): Apache HTTP Server Privilege Escalation (high 7.8, exploited in the wild)
- [CVE-2021-41773](https://insights.sbomify.com/CVE-2021-41773/): Apache HTTP Server Path Traversal (high 7.5, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2007-0450 and fix it if it is affected.

What it is: CVE-2007-0450 is a medium-severity path traversal vulnerability in Apache Http Server, published on 16 Mar 2007. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2007-0450 exists.

Affected packages and fixed versions:
- org.apache.tomcat:tomcat (Maven): affected from 5.0; fixed in 5.5.22
- org.apache.tomcat:tomcat (Maven): affected from 5.0; fixed in 5.5.22
- org.apache.tomcat:tomcat (Maven): affected from 6.0; fixed in 6.0.10
- org.apache.tomcat:tomcat (Maven): affected from 6.0; fixed in 6.0.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2007-0450/ (Markdown: https://insights.sbomify.com/CVE-2007-0450/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2007-0450
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2007-0450
- OSV: https://osv.dev/vulnerability/CVE-2007-0450

---
From sbomify Insights: https://insights.sbomify.com/CVE-2007-0450/
Summaries are generated and may contain mistakes; the official description above is the record.
