{"answers":{"affected":"2 open source packages ship an affected version, including rubygems-update. It affects 1 product.","exploited":"There is no known exploitation of CVE-2007-0469 in the wild and no public exploit code.","fix":"Upgrade rubygems-update to 0.9.1 or later.","what":"CVE-2007-0469 is a critical path traversal vulnerability in n/a, published on 24 Jan 2007. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2007-0469 and fix it if it is affected.\n\nWhat it is: CVE-2007-0469 is a critical path traversal vulnerability in n/a, published on 24 Jan 2007. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2007-0469 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- rubygems-update (RubyGems): affected all versions; fixed in 0.9.1\n- rubygems-update (RubyGems): affected all versions; fixed in 0.9.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2007-0469/ (Markdown: https://insights.sbomify.com/CVE-2007-0469/index.md)","id":"CVE-2007-0469","markdown":"https://insights.sbomify.com/CVE-2007-0469/index.md","name":"CVE-2007-0469","record":{"aliases":["GHSA-95vx-q4c2-64gr"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"RubyGems package manager","requires_auth":"none","summary":"Attackers can overwrite arbitrary files and execute code via crafted GEM packages, requiring user interaction to install the malicious package.","user_interaction":"required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"rubygems","vendor":"rubyforge"}],"cvss":{"score":9.3,"severity":"critical","source":"nvd","vector":"AV:N/AC:M/Au:N/C:C/I:C/A:C","version":"2.0"},"cwes":[],"description":"The extract_files function in installer.rb in RubyGems before 0.9.1 does not check whether files exist before overwriting them, which allows user-assisted remote attackers to overwrite arbitrary files, cause a denial of service, or execute arbitrary code via crafted GEM packages.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"RubyGems file overwrite vulnerability","id":"CVE-2007-0469","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"path_traversal","year":"2007"},"n_packages":2,"n_references":6,"next":{"headline":"Privilege escalation in n/a","id":"CVE-2007-0470"},"packages":[{"ecosystem":"RubyGems","fixed":["0.9.1"],"introduced":["0"],"last_affected":[],"package":"rubygems-update","purl":null,"source":"GHSA-95vx-q4c2-64gr"},{"ecosystem":"RubyGems","fixed":["0.9.1"],"introduced":["0"],"last_affected":[],"package":"rubygems-update","purl":"pkg:gem/rubygems-update","source":"GHSA-95vx-q4c2-64gr"}],"prev":{"headline":"Stack-based buffer overflow in rcdll.dll in msdev.exe in Visual C++ (MSVC) in Microsoft Visual Studio 6.0 SP6 allows user-assisted remote at","id":"CVE-2007-0468"},"products":["n/a"],"published":"2007-01-24","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-07","vendors":["n/a"]},"summary":"Attackers can overwrite arbitrary files and execute code via crafted GEM packages, requiring user interaction to install the malicious package.","url":"https://insights.sbomify.com/CVE-2007-0469/"}