{"answers":{"affected":"2 open source packages ship an affected version, including DotNetNuke.Core. It affects 1 product.","exploited":"There is no known exploitation of CVE-2007-0660 in the wild and no public exploit code.","fix":"Upgrade DotNetNuke.Core to 03.02.01 or later.","what":"CVE-2007-0660 is a medium-severity cross-site scripting vulnerability in n/a, published on 1 Feb 2007. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2007-0660 and fix it if it is affected.\n\nWhat it is: CVE-2007-0660 is a medium-severity cross-site scripting vulnerability in n/a, published on 1 Feb 2007. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2007-0660 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- DotNetNuke.Core (NuGet): affected all versions; fixed in 03.02.01\n- DotNetNuke.Core (NuGet): affected all versions; fixed in 03.02.01\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2007-0660/ (Markdown: https://insights.sbomify.com/CVE-2007-0660/index.md)","id":"CVE-2007-0660","markdown":"https://insights.sbomify.com/CVE-2007-0660/index.md","name":"CVE-2007-0660","record":{"aliases":["GHSA-xr96-7ccp-pg5c"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"DotNetNuke IFrame module","requires_auth":"low_privilege","summary":"Remote attackers can inject arbitrary web script or HTML via the IFrame module, potentially leading to session hijacking or malicious actions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"dotnetnuke_iframe","vendor":"dotnetnuke"}],"cvss":{"score":6.8,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:P/I:P/A:P","version":"2.0"},"cwes":[],"description":"Cross-site scripting (XSS) vulnerability in the IFrame module before 03.02.01 for DotNetNuke (DNN) allows remote attackers to inject arbitrary web script or HTML via unspecified vectors related to \"Pass through values.\"","ecosystems":["NuGet"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"DotNetNuke Vulnerable to XSS in Pass-Through Values","id":"CVE-2007-0660","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"NuGet","product":null,"products":[],"type":"xss","year":"2007"},"n_packages":2,"n_references":5,"next":{"headline":"Missing authorization in n/a","id":"CVE-2007-0661"},"packages":[{"ecosystem":"NuGet","fixed":["03.02.01"],"introduced":["0"],"last_affected":[],"package":"DotNetNuke.Core","purl":null,"source":"GHSA-xr96-7ccp-pg5c"},{"ecosystem":"NuGet","fixed":["03.02.01"],"introduced":["0"],"last_affected":[],"package":"DotNetNuke.Core","purl":"pkg:nuget/DotNetNuke.Core","source":"GHSA-xr96-7ccp-pg5c"}],"prev":{"headline":"Path traversal in n/a","id":"CVE-2007-0659"},"products":["n/a"],"published":"2007-02-01","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-07","vendors":["n/a"]},"summary":"Remote attackers can inject arbitrary web script or HTML via the IFrame module, potentially leading to session hijacking or malicious actions.","url":"https://insights.sbomify.com/CVE-2007-0660/"}