{"answers":{"affected":"3 open source packages ship an affected version, including moin and Moin. It affects 1 product.","exploited":"There is no known exploitation of CVE-2007-0901 in the wild and no public exploit code.","fix":"Upgrade moin to 1.5.8 or later.","what":"CVE-2007-0901 is a medium-severity cross-site scripting vulnerability in n/a, published on 13 Feb 2007. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2007-0901 and fix it if it is affected.\n\nWhat it is: CVE-2007-0901 is a medium-severity cross-site scripting vulnerability in n/a, published on 13 Feb 2007. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2007-0901 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- moin (PyPI): affected all versions; fixed in 1.5.8\n- moin (PyPI): affected all versions; fixed in 1.5.8\n- Moin (PyPI): affected all versions; fixed in 1.5.8\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2007-0901/ (Markdown: https://insights.sbomify.com/CVE-2007-0901/index.md)","id":"CVE-2007-0901","markdown":"https://insights.sbomify.com/CVE-2007-0901/index.md","name":"CVE-2007-0901","record":{"aliases":["GHSA-9gj2-ph57-56f5","PYSEC-2026-673"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"MoinMoin Wiki","requires_auth":"none","summary":"Remote attackers can inject arbitrary web script or HTML into MoinMoin Wiki Info pages via specific parameters, requiring user interaction to execute.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"moinmoin","vendor":"moinmoin"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:N/I:P/A:N","version":"2.0"},"cwes":[],"description":"Multiple cross-site scripting (XSS) vulnerabilities in Info pages in MoinMoin 1.5.7 allow remote attackers to inject arbitrary web script or HTML via the (1) hitcounts and (2) general parameters, different vectors than CVE-2007-0857.  NOTE: the provenance of this information is unknown; the details are obtained solely from third party information.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"MoinMoin Cross-Site Scripting (XSS) vulnerability via hitcounts and general parameters","id":"CVE-2007-0901","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"xss","year":"2007"},"n_packages":3,"n_references":5,"next":{"headline":"MoinMoin Insertion of Sensitive Information into Log File","id":"CVE-2007-0902"},"packages":[{"ecosystem":"PyPI","fixed":["1.5.8"],"introduced":["0"],"last_affected":[],"package":"Moin","purl":null,"source":"GHSA-9gj2-ph57-56f5"},{"ecosystem":"PyPI","fixed":["1.5.8"],"introduced":["0"],"last_affected":[],"package":"moin","purl":"pkg:pypi/moin","source":"GHSA-9gj2-ph57-56f5"},{"ecosystem":"PyPI","fixed":["1.5.8"],"introduced":["0"],"last_affected":[],"package":"moin","purl":"pkg:pypi/moin","source":"PYSEC-2026-673"}],"prev":{"headline":"Code injection in n/a","id":"CVE-2007-0900"},"products":["n/a"],"published":"2007-02-13","related":[{"cvss_score":10,"headline":"MoinMoin Improper Privilege Management","id":"CVE-2004-1463","kev_date_added":null,"published":"2005-02-13"},{"cvss_score":7.5,"headline":"MoinMoin Improper Access Control","id":"CVE-2004-1462","kev_date_added":null,"published":"2005-02-13"},{"cvss_score":7.5,"headline":"MoinMoin allows administrative access","id":"CVE-2004-0708","kev_date_added":null,"published":"2004-07-21"},{"cvss_score":6.8,"headline":"MoinMoin vulnerable to privilege escalation","id":"CVE-2008-1937","kev_date_added":null,"published":"2008-04-24"},{"cvss_score":5.8,"headline":"Cross-site scripting in n/a","id":"CVE-2007-2423","kev_date_added":null,"published":"2007-05-02"},{"cvss_score":5,"headline":"MoinMoin Improper Access Control","id":"CVE-2008-1099","kev_date_added":null,"published":"2008-03-05"},{"cvss_score":5,"headline":"MoinMoin Directory traversal vulnerability","id":"CVE-2008-0782","kev_date_added":null,"published":"2008-02-14"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-07","vendors":["n/a"]},"summary":"Remote attackers can inject arbitrary web script or HTML into MoinMoin Wiki Info pages via specific parameters, requiring user interaction to execute.","url":"https://insights.sbomify.com/CVE-2007-0901/"}