# CVE-2007-0901: MoinMoin Cross-Site Scripting (XSS) vulnerability via hitcounts and general parameters

> Remote attackers can inject arbitrary web script or HTML into MoinMoin Wiki Info pages via specific parameters, requiring user interaction to execute.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 13 Feb 2007
- **Updated:** 7 Aug 2024
- **Also known as:** GHSA-9gj2-ph57-56f5, PYSEC-2026-673

## What is CVE-2007-0901?

CVE-2007-0901 is a medium-severity cross-site scripting vulnerability in n/a, published on 13 Feb 2007. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Multiple cross-site scripting (XSS) vulnerabilities in Info pages in MoinMoin 1.5.7 allow remote attackers to inject arbitrary web script or HTML via the (1) hitcounts and (2) general parameters, different vectors than CVE-2007-0857.  NOTE: the provenance of this information is unknown; the details are obtained solely from third party information.

## Which versions are affected by CVE-2007-0901?

3 open source packages ship an affected version, including moin and Moin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `moin` | PyPI | All versions | 1.5.8 |
| `moin` | PyPI | All versions | 1.5.8 |
| `Moin` | PyPI | All versions | 1.5.8 |

Products: Moinmoin Moinmoin.

## How do I fix CVE-2007-0901?

Upgrade moin to 1.5.8 or later.

## Is CVE-2007-0901 being exploited?

There is no known exploitation of CVE-2007-0901 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2004-1463](https://insights.sbomify.com/CVE-2004-1463/): MoinMoin Improper Privilege Management (critical 10.0)
- [CVE-2004-1462](https://insights.sbomify.com/CVE-2004-1462/): MoinMoin Improper Access Control (high 7.5)
- [CVE-2004-0708](https://insights.sbomify.com/CVE-2004-0708/): MoinMoin allows administrative access (high 7.5)
- [CVE-2008-1937](https://insights.sbomify.com/CVE-2008-1937/): MoinMoin vulnerable to privilege escalation (medium 6.8)
- [CVE-2007-2423](https://insights.sbomify.com/CVE-2007-2423/): Cross-site scripting in n/a (medium 5.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2007-0901 and fix it if it is affected.

What it is: CVE-2007-0901 is a medium-severity cross-site scripting vulnerability in n/a, published on 13 Feb 2007. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2007-0901 in the wild and no public exploit code.

Affected packages and fixed versions:
- moin (PyPI): affected all versions; fixed in 1.5.8
- moin (PyPI): affected all versions; fixed in 1.5.8
- Moin (PyPI): affected all versions; fixed in 1.5.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2007-0901/ (Markdown: https://insights.sbomify.com/CVE-2007-0901/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2007-0901
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2007-0901
- OSV: https://osv.dev/vulnerability/CVE-2007-0901

---
From sbomify Insights: https://insights.sbomify.com/CVE-2007-0901/
Summaries are generated and may contain mistakes; the official description above is the record.
