# CVE-2007-0902: MoinMoin Insertion of Sensitive Information into Log File

> Remote attackers can obtain sensitive information via the debugging feature in MoinMoin wiki software.

- **Severity:** Medium 5.0 (`AV:N/AC:L/Au:N/C:P/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not stated
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Feb 2007
- **Updated:** 7 Aug 2024
- **Also known as:** GHSA-mxh8-xgq9-w782, PYSEC-2026-679

## What is CVE-2007-0902?

CVE-2007-0902 is a medium-severity vulnerability in n/a, published on 13 Feb 2007. It can be exploited over the network, with no action from the victim.

### Official description

Unspecified vulnerability in the "Show debugging information" feature in MoinMoin 1.5.7 allows remote attackers to obtain sensitive information.  NOTE: the provenance of this information is unknown; the details are obtained solely from third party information.

## Which versions are affected by CVE-2007-0902?

3 open source packages ship an affected version, including moin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `moin` | PyPI | From 1.5.7 | 1.5.8 |
| `moin` | PyPI | From 1.5.7 | 1.5.8 |
| `moin` | PyPI | From 1.5.7 | 1.5.8 |

Products: Moinmoin Moinmoin.

## How do I fix CVE-2007-0902?

Upgrade moin to 1.5.8 or later.

## Is CVE-2007-0902 being exploited?

There is no known exploitation of CVE-2007-0902 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2004-1463](https://insights.sbomify.com/CVE-2004-1463/): MoinMoin Improper Privilege Management (critical 10.0)
- [CVE-2004-1462](https://insights.sbomify.com/CVE-2004-1462/): MoinMoin Improper Access Control (high 7.5)
- [CVE-2004-0708](https://insights.sbomify.com/CVE-2004-0708/): MoinMoin allows administrative access (high 7.5)
- [CVE-2008-1937](https://insights.sbomify.com/CVE-2008-1937/): MoinMoin vulnerable to privilege escalation (medium 6.8)
- [CVE-2007-2423](https://insights.sbomify.com/CVE-2007-2423/): Cross-site scripting in n/a (medium 5.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2007-0902 and fix it if it is affected.

What it is: CVE-2007-0902 is a medium-severity vulnerability in n/a, published on 13 Feb 2007. It can be exploited over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2007-0902 in the wild and no public exploit code.

Affected packages and fixed versions:
- moin (PyPI): affected from 1.5.7; fixed in 1.5.8
- moin (PyPI): affected from 1.5.7; fixed in 1.5.8
- moin (PyPI): affected from 1.5.7; fixed in 1.5.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2007-0902/ (Markdown: https://insights.sbomify.com/CVE-2007-0902/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2007-0902
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2007-0902
- OSV: https://osv.dev/vulnerability/CVE-2007-0902

---
From sbomify Insights: https://insights.sbomify.com/CVE-2007-0902/
Summaries are generated and may contain mistakes; the official description above is the record.
