CVE-2007-10003 The Hackers Diet Plugin HTTP POST Request ajax_blurb.php sql injection

Medium 6.3 Published Updated

Remote attackers can exploit SQL injection in the Hackers Diet Plugin to read or modify database contents.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2007-10003?

CVE-2007-10003 is a medium-severity SQL injection vulnerability in The Hackers Diet Plugin, published on 29 Oct 2023. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

A vulnerability, which was classified as critical, has been found in The Hackers Diet Plugin up to 0.9.6b on WordPress. This issue affects some unknown processing of the file ajax_blurb.php of the component HTTP POST Request Handler. The manipulation of the argument user leads to sql injection. The attack may be initiated remotely. Upgrading to version 0.9.7b is able to address this issue. The patch is named 7dd8acf7cd8442609840037121074425d363b694. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-243803.

Weakness: CWE-89

Which versions are affected by CVE-2007-10003?

It affects 1 product.

Products include Wp-Plugins the Hackers Diet.

How do I fix CVE-2007-10003?

No fix has been published for CVE-2007-10003 yet. Limit exposure of the affected software until one is available.

Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.

Is CVE-2007-10003 being exploited?

There is no known exploitation of CVE-2007-10003 in the wild and no public exploit code.

Sources

Also known as GHSA-24m5-fqmm-mrmv.

Is CVE-2007-10003 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free