# CVE-2007-10003: The Hackers Diet Plugin HTTP POST Request ajax_blurb.php sql injection

> Remote attackers can exploit SQL injection in the Hackers Diet Plugin to read or modify database contents.

- **Severity:** Medium 6.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 29 Oct 2023
- **Updated:** 6 Sep 2024
- **Also known as:** GHSA-24m5-fqmm-mrmv

## What is CVE-2007-10003?

CVE-2007-10003 is a medium-severity SQL injection vulnerability in The Hackers Diet Plugin, published on 29 Oct 2023. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A vulnerability, which was classified as critical, has been found in The Hackers Diet Plugin up to 0.9.6b on WordPress. This issue affects some unknown processing of the file ajax_blurb.php of the component HTTP POST Request Handler. The manipulation of the argument user leads to sql injection. The attack may be initiated remotely. Upgrading to version 0.9.7b is able to address this issue. The patch is named 7dd8acf7cd8442609840037121074425d363b694. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-243803.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2007-10003?

It affects 1 product.


Products: Wp-Plugins the Hackers Diet.

## How do I fix CVE-2007-10003?

No fix has been published for CVE-2007-10003 yet. Limit exposure of the affected software until one is available.

## Is CVE-2007-10003 being exploited?

There is no known exploitation of CVE-2007-10003 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2007-10003 and fix it if it is affected.

What it is: CVE-2007-10003 is a medium-severity SQL injection vulnerability in The Hackers Diet Plugin, published on 29 Oct 2023. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2007-10003 in the wild and no public exploit code.

Affected product: The Hackers Diet Plugin. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2007-10003/ (Markdown: https://insights.sbomify.com/CVE-2007-10003/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2007-10003
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2007-10003
- OSV: https://osv.dev/vulnerability/CVE-2007-10003

---
From sbomify Insights: https://insights.sbomify.com/CVE-2007-10003/
Summaries are generated and may contain mistakes; the official description above is the record.
