CVE-2007-1355 Apache Tomcat Vulnerable to Cross-Site Scripting
Remote attackers can inject arbitrary web script via the test parameter in the Tomcat sample application, requiring user interaction to execute.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2007-1355?
CVE-2007-1355 is a medium-severity cross-site scripting vulnerability in Apache Tomcat, published on 21 May 2007. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Multiple cross-site scripting (XSS) vulnerabilities in the appdev/sample/web/hello.jsp example application in Tomcat 4.0.0 through 4.0.6, 4.1.0 through 4.1.36, 5.0.0 through 5.0.30, 5.5.0 through 5.5.23, and 6.0.0 through 6.0.10 allow remote attackers to inject arbitrary web script or HTML via the test parameter and unspecified vectors.
Which versions are affected by CVE-2007-1355?
20 open source packages ship an affected version, including org.apache.tomcat:jsp-api and org.apache.tomcat:servlet-api. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.tomcat:jsp-api Maven | From 4.0.0 to 4.0.6 | None |
org.apache.tomcat:jsp-api Maven | From 4.0.0 to 4.0.6 | None |
org.apache.tomcat:jsp-api Maven | From 4.1.0 | 4.1.37 |
org.apache.tomcat:jsp-api Maven | From 4.1.0 | 4.1.37 |
org.apache.tomcat:jsp-api Maven | From 5.0.0 to 5.0.30 | None |
org.apache.tomcat:jsp-api Maven | From 5.0.0 to 5.0.30 | None |
14 more packages
org.apache.tomcat:jsp-api Maven | From 5.5.0 | 5.5.24 |
org.apache.tomcat:jsp-api Maven | From 5.5.0 | 5.5.24 |
org.apache.tomcat:jsp-api Maven | From 6.0.0 | 6.0.11 |
org.apache.tomcat:jsp-api Maven | From 6.0.0 | 6.0.11 |
org.apache.tomcat:servlet-api Maven | From 4.0.0 to 4.0.6 | None |
org.apache.tomcat:servlet-api Maven | From 4.0.0 to 4.0.6 | None |
org.apache.tomcat:servlet-api Maven | From 4.1.0 | 4.1.37 |
org.apache.tomcat:servlet-api Maven | From 4.1.0 | 4.1.37 |
org.apache.tomcat:servlet-api Maven | From 5.0.0 to 5.0.30 | None |
org.apache.tomcat:servlet-api Maven | From 5.0.0 to 5.0.30 | None |
org.apache.tomcat:servlet-api Maven | From 5.5.0 | 5.5.24 |
org.apache.tomcat:servlet-api Maven | From 5.5.0 | 5.5.24 |
org.apache.tomcat:servlet-api Maven | From 6.0.0 | 6.0.11 |
org.apache.tomcat:servlet-api Maven | From 6.0.0 | 6.0.11 |
Products include Apache Tomcat.
How do I fix CVE-2007-1355?
Upgrade org.apache.tomcat:jsp-api to a fixed version for your release line: 4.1.37, 5.5.24 or 6.0.11.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2007-1355 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2007-1355 exists.
Public exploit code: 1 Exploit-DB entry.
Other vulnerabilities in Apache Tomcat
Sources
Also known as GHSA-4c6x-gfc8-c26r.