# CVE-2007-1406: Trac missing Content-Disposition HTTP header

> Trac fails to set Content-Disposition headers for attachments in unsafe situations, potentially allowing unintended file handling by remote attackers.

- **Severity:** Critical 10.0 (`AV:N/AC:L/Au:N/C:C/I:C/A:C`)
- **Exploited in the wild:** Not known
- **Login needed:** Not stated
- **Attackable:** Over the internet
- **Victim action needed:** Not stated
- **Fix available:** Yes
- **Published:** 10 Mar 2007
- **Updated:** 16 Sep 2024
- **Also known as:** DEBIAN-CVE-2007-1406, GHSA-7jjr-3r8r-9pcf, PYSEC-2007-3

## What is CVE-2007-1406?

CVE-2007-1406 is a critical vulnerability in n/a, published on 10 Mar 2007. It can be exploited over the network.

### Official description

Trac before 0.10.3.1 does not send a Content-Disposition HTTP header specifying an attachment in certain "unsafe" situations, which has unknown impact and remote attack vectors.

## Which versions are affected by CVE-2007-1406?

3 open source packages ship an affected version, including trac. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `trac` | PyPI | All versions | 0.10.3.1 |
| `trac` | PyPI | All versions | 0.10.3.1 |
| `trac` | PyPI | All versions | 0.10.3.1 |

Products: Edgewall Software Trac.

## How do I fix CVE-2007-1406?

Upgrade trac to 0.10.3.1 or later.

## Is CVE-2007-1406 being exploited?

There is no known exploitation of CVE-2007-1406 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2006-5878](https://insights.sbomify.com/CVE-2006-5878/): Edgewall Trac Cross-site request forgery (CSRF) vulnerability (high 7.5)
- [CVE-2005-4065](https://insights.sbomify.com/CVE-2005-4065/): SQL injection in n/a (high 7.5)
- [CVE-2005-3980](https://insights.sbomify.com/CVE-2005-3980/): SQL injection in n/a (high 7.5)
- [CVE-2006-3695](https://insights.sbomify.com/CVE-2006-3695/): Trac reStructuredText breach of privacy and denial of service vulnerability (medium 6.8)
- [CVE-2005-2147](https://insights.sbomify.com/CVE-2005-2147/): Path traversal in n/a (medium 6.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2007-1406 and fix it if it is affected.

What it is: CVE-2007-1406 is a critical vulnerability in n/a, published on 10 Mar 2007. It can be exploited over the network.
Exploitation: There is no known exploitation of CVE-2007-1406 in the wild and no public exploit code.

Affected packages and fixed versions:
- trac (PyPI): affected all versions; fixed in 0.10.3.1
- trac (PyPI): affected all versions; fixed in 0.10.3.1
- trac (PyPI): affected all versions; fixed in 0.10.3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2007-1406/ (Markdown: https://insights.sbomify.com/CVE-2007-1406/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2007-1406
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2007-1406
- OSV: https://osv.dev/vulnerability/CVE-2007-1406

---
From sbomify Insights: https://insights.sbomify.com/CVE-2007-1406/
Summaries are generated and may contain mistakes; the official description above is the record.
