{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2007-2348 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2007-2348 is a medium-severity command injection vulnerability in n/a, published on 27 Apr 2007. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2007-2348 and fix it if it is affected.\n\nWhat it is: CVE-2007-2348 is a medium-severity command injection vulnerability in n/a, published on 27 Apr 2007. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2007-2348 in the wild and no public exploit code.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2007-2348/ (Markdown: https://insights.sbomify.com/CVE-2007-2348/index.md)","id":"CVE-2007-2348","markdown":"https://insights.sbomify.com/CVE-2007-2348/index.md","name":"CVE-2007-2348","record":{"aliases":["DEBIAN-CVE-2007-2348","GHSA-m4hr-2hrx-m38c","RHSA-2009:1278"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"lftp command line tool","requires_auth":"none","summary":"Remote attackers can execute arbitrary shell commands via malicious scripts in lftp, requiring user assistance to run the script.","user_interaction":"required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"lftp","vendor":"alexander_v._lukyanov"}],"cvss":{"score":6.8,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:P/I:P/A:P","version":"2.0"},"cwes":[],"description":"mirror --script in lftp before 3.5.9 does not properly quote shell metacharacters, which might allow remote user-assisted attackers to execute shell commands via a malicious script.  NOTE: it is not clear whether this issue crosses security boundaries, since the script already supports commands such as \"get\" which could overwrite executable files.","ecosystems":["Red Hat:enterprise_linux:5::client","Red Hat:enterprise_linux:5::server"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Command injection in n/a","id":"CVE-2007-2348","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"command_injection","year":"2007"},"n_packages":4,"n_references":10,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2007-2349"},"packages":[{"ecosystem":"Red Hat:enterprise_linux:5::client","fixed":["0:3.7.11-4.el5"],"introduced":["0"],"last_affected":[],"package":"lftp","purl":"pkg:rpm/redhat/lftp","source":"RHSA-2009:1278"},{"ecosystem":"Red Hat:enterprise_linux:5::client","fixed":["0:3.7.11-4.el5"],"introduced":["0"],"last_affected":[],"package":"lftp-debuginfo","purl":"pkg:rpm/redhat/lftp-debuginfo","source":"RHSA-2009:1278"},{"ecosystem":"Red Hat:enterprise_linux:5::server","fixed":["0:3.7.11-4.el5"],"introduced":["0"],"last_affected":[],"package":"lftp","purl":"pkg:rpm/redhat/lftp","source":"RHSA-2009:1278"},{"ecosystem":"Red Hat:enterprise_linux:5::server","fixed":["0:3.7.11-4.el5"],"introduced":["0"],"last_affected":[],"package":"lftp-debuginfo","purl":"pkg:rpm/redhat/lftp-debuginfo","source":"RHSA-2009:1278"}],"prev":{"headline":"Code injection in n/a","id":"CVE-2007-2347"},"products":["n/a"],"published":"2007-04-27","related":[{"cvss_score":7.5,"headline":"Path traversal in n/a","id":"CVE-2010-2251","kev_date_added":null,"published":"2010-07-06"},{"cvss_score":7.5,"headline":"Memory corruption in n/a","id":"CVE-2003-0963","kev_date_added":null,"published":"2003-12-17"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"Red Hat","prefix":"RHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-07","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary shell commands via malicious scripts in lftp, requiring user assistance to run the script.","url":"https://insights.sbomify.com/CVE-2007-2348/"}