CVE-2007-2450 Apache Tomcat vulnerable to Cross-site Scripting

Low 3.5 Published Updated

Authenticated users can inject arbitrary scripts into Tomcat Manager interfaces, potentially leading to session hijacking or code execution.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2007-2450?

CVE-2007-2450 is a low-severity cross-site scripting vulnerability in Apache Tomcat, published on 14 Jun 2007. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

Multiple cross-site scripting (XSS) vulnerabilities in the (1) Manager and (2) Host Manager web applications in Apache Tomcat 4.0.0 through 4.0.6, 4.1.0 through 4.1.36, 5.0.0 through 5.0.30, 5.5.0 through 5.5.24, and 6.0.0 through 6.0.13 allow remote authenticated users to inject arbitrary web script or HTML via a parameter name to manager/html/upload, and other unspecified vectors.

Weakness: CWE-79

Which versions are affected by CVE-2007-2450?

10 open source packages ship an affected version, including org.apache.tomcat:tomcat. It affects 1 product.

PackageAffectedFixed in
org.apache.tomcat:tomcat MavenFrom 4.0.0 to 4.0.6None
org.apache.tomcat:tomcat MavenFrom 4.0.0 to 4.0.6None
org.apache.tomcat:tomcat MavenFrom 4.1.04.1.37
org.apache.tomcat:tomcat MavenFrom 4.1.04.1.37
org.apache.tomcat:tomcat MavenFrom 5.0.0 to 5.0.30None
org.apache.tomcat:tomcat MavenFrom 5.0.0 to 5.0.30None
4 more packages
org.apache.tomcat:tomcat MavenFrom 5.5.05.5.25
org.apache.tomcat:tomcat MavenFrom 5.5.05.5.25
org.apache.tomcat:tomcat MavenFrom 6.0.06.0.14
org.apache.tomcat:tomcat MavenFrom 6.0.06.0.14

Products include Apache Tomcat.

How do I fix CVE-2007-2450?

Upgrade org.apache.tomcat:tomcat to a fixed version for your release line: 4.1.37, 5.5.25 or 6.0.14.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2007-2450 being exploited?

There is no known exploitation of CVE-2007-2450 in the wild and no public exploit code.

All Apache Tomcat vulnerabilities

Sources

Also known as GHSA-5c5p-jxvx-x7j2.

Is CVE-2007-2450 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free