{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2007-3126 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2007-3126 is a medium-severity denial of service vulnerability in Gimp Gimp, published on 8 Jun 2007. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2007-3126 and fix it if it is affected.\n\nWhat it is: CVE-2007-3126 is a medium-severity denial of service vulnerability in Gimp Gimp, published on 8 Jun 2007. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2007-3126 in the wild and no public exploit code.\n\nAffected product: Gimp Gimp. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2007-3126/ (Markdown: https://insights.sbomify.com/CVE-2007-3126/index.md)","id":"CVE-2007-3126","markdown":"https://insights.sbomify.com/CVE-2007-3126/index.md","name":"CVE-2007-3126","record":{"aliases":["DEBIAN-CVE-2007-3126","GHSA-4vhr-6jhx-vf2q","MGASA-2017-0112","SUSE-SU-2017:0945-1"],"analysis":{"component_type":"desktop_application","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"GIMP image editor","requires_auth":"none","summary":"An attacker can cause a crash in GIMP by tricking a user into opening a specially crafted ICO file with a zero height value.","user_interaction":"required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"gimp","vendor":"gimp"}],"cvss":{"score":5,"severity":"medium","source":"nvd","vector":"AV:N/AC:L/Au:N/C:N/I:N/A:P","version":"2.0"},"cwes":[],"description":"Gimp before 2.8.22 allows context-dependent attackers to cause a denial of service (crash) via an ICO file with an InfoHeader containing a Height of zero, a similar issue to CVE-2007-2237.","ecosystems":["SUSE:Linux Enterprise Desktop 12 SP2","SUSE:Linux Enterprise Software Development Kit 12 SP2","SUSE:Linux Enterprise Workstation Extension 12 SP2"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of service in n/a","id":"CVE-2007-3126","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"gimp:gimp","products":["gimp:gimp"],"type":"denial_of_service","year":"2007"},"n_packages":3,"n_references":6,"next":{"headline":"Information disclosure in n/a","id":"CVE-2007-3127"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Desktop 12 SP2","fixed":["2.8.18-8.1"],"introduced":["0"],"last_affected":[],"package":"gimp","purl":"pkg:rpm/suse/gimp\u0026distro=SUSE%20Linux%20Enterprise%20Desktop%2012%20SP2","source":"SUSE-SU-2017:0945-1"},{"ecosystem":"SUSE:Linux Enterprise Software Development Kit 12 SP2","fixed":["2.8.18-8.1"],"introduced":["0"],"last_affected":[],"package":"gimp","purl":"pkg:rpm/suse/gimp\u0026distro=SUSE%20Linux%20Enterprise%20Software%20Development%20Kit%2012%20SP2","source":"SUSE-SU-2017:0945-1"},{"ecosystem":"SUSE:Linux Enterprise Workstation Extension 12 SP2","fixed":["2.8.18-8.1"],"introduced":["0"],"last_affected":[],"package":"gimp","purl":"pkg:rpm/suse/gimp\u0026distro=SUSE%20Linux%20Enterprise%20Workstation%20Extension%2012%20SP2","source":"SUSE-SU-2017:0945-1"}],"prev":{"headline":"Memory corruption in n/a","id":"CVE-2007-3124"},"products":["n/a"],"published":"2007-06-08","related":[{"cvss_score":9.3,"headline":"Memory corruption in n/a","id":"CVE-2010-4541","kev_date_added":null,"published":"2011-01-07"},{"cvss_score":9.3,"headline":"Integer overflow in n/a","id":"CVE-2009-3909","kev_date_added":null,"published":"2009-11-19"},{"cvss_score":9.3,"headline":"Integer overflow in n/a","id":"CVE-2009-1570","kev_date_added":null,"published":"2009-11-13"},{"cvss_score":9.3,"headline":"Integer overflow in n/a","id":"CVE-2009-0723","kev_date_added":null,"published":"2009-03-23"},{"cvss_score":9.3,"headline":"Memory corruption in n/a","id":"CVE-2009-0733","kev_date_added":null,"published":"2009-03-23"},{"cvss_score":9.1,"headline":"Race condition in n/a","id":"CVE-2018-12713","kev_date_added":null,"published":"2018-06-24"},{"cvss_score":8.4,"headline":"Gimp: gimp: arbitrary code execution in psd plugin due to unsigned underflow","id":"CVE-2026-59090","kev_date_added":null,"published":"2026-08-10"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-07","vendors":["n/a"]},"summary":"An attacker can cause a crash in GIMP by tricking a user into opening a specially crafted ICO file with a zero height value.","url":"https://insights.sbomify.com/CVE-2007-3126/"}