{"answers":{"affected":"2 open source packages ship an affected version, including phpmailer/phpmailer. It affects 1 product.","exploited":"There is no known exploitation of CVE-2007-3215 in the wild and no public exploit code.","fix":"Upgrade phpmailer/phpmailer to 1.7.4 or later.","what":"CVE-2007-3215 is a medium-severity command injection vulnerability in n/a, published on 14 Jun 2007. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2007-3215 and fix it if it is affected.\n\nWhat it is: CVE-2007-3215 is a medium-severity command injection vulnerability in n/a, published on 14 Jun 2007. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2007-3215 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- phpmailer/phpmailer (Packagist): affected all versions; fixed in 1.7.4\n- phpmailer/phpmailer (Packagist): affected all versions; fixed in 1.7.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2007-3215/ (Markdown: https://insights.sbomify.com/CVE-2007-3215/index.md)","id":"CVE-2007-3215","markdown":"https://insights.sbomify.com/CVE-2007-3215/index.md","name":"CVE-2007-3215","record":{"aliases":["DEBIAN-CVE-2007-3215","DSA-1315-1","GHSA-6h78-85v2-mmch"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"PHP email library","requires_auth":"none","summary":"Remote attackers can execute arbitrary shell commands in PHPMailer when configured to use sendmail, requiring immediate library upgrades.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"phpmailer","vendor":"phpmailer"}],"cvss":{"score":6.8,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:P/I:P/A:P","version":"2.0"},"cwes":[],"description":"PHPMailer 1.7, when configured to use sendmail, allows remote attackers to execute arbitrary shell commands via shell metacharacters in the SendmailSend function in class.phpmailer.php.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"PHPMailer Shell command injection","id":"CVE-2007-3215","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"command_injection","year":"2007"},"n_packages":2,"n_references":17,"next":{"headline":"Memory corruption in n/a","id":"CVE-2007-3216"},"packages":[{"ecosystem":"Packagist","fixed":["1.7.4"],"introduced":["0"],"last_affected":[],"package":"phpmailer/phpmailer","purl":null,"source":"GHSA-6h78-85v2-mmch"},{"ecosystem":"Packagist","fixed":["1.7.4"],"introduced":["0"],"last_affected":[],"package":"phpmailer/phpmailer","purl":"pkg:composer/phpmailer/phpmailer","source":"GHSA-6h78-85v2-mmch"}],"prev":{"headline":"SQL injection in n/a","id":"CVE-2007-3214"},"products":["n/a"],"published":"2007-06-14","related":[{"cvss_score":5,"headline":"Denial of service in n/a","id":"CVE-2005-1807","kev_date_added":null,"published":"2005-06-01"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-07","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary shell commands in PHPMailer when configured to use sendmail, requiring immediate library upgrades.","url":"https://insights.sbomify.com/CVE-2007-3215/"}