# CVE-2007-3215: PHPMailer Shell command injection

> Remote attackers can execute arbitrary shell commands in PHPMailer when configured to use sendmail, requiring immediate library upgrades.

- **Severity:** Medium 6.8 (`AV:N/AC:M/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Jun 2007
- **Updated:** 7 Aug 2024
- **Also known as:** DEBIAN-CVE-2007-3215, DSA-1315-1, GHSA-6h78-85v2-mmch

## What is CVE-2007-3215?

CVE-2007-3215 is a medium-severity command injection vulnerability in n/a, published on 14 Jun 2007. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

PHPMailer 1.7, when configured to use sendmail, allows remote attackers to execute arbitrary shell commands via shell metacharacters in the SendmailSend function in class.phpmailer.php.

## Which versions are affected by CVE-2007-3215?

2 open source packages ship an affected version, including phpmailer/phpmailer. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpmailer/phpmailer` | Packagist | All versions | 1.7.4 |
| `phpmailer/phpmailer` | Packagist | All versions | 1.7.4 |

Products: Phpmailer Phpmailer.

## How do I fix CVE-2007-3215?

Upgrade phpmailer/phpmailer to 1.7.4 or later.

## Is CVE-2007-3215 being exploited?

There is no known exploitation of CVE-2007-3215 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2005-1807](https://insights.sbomify.com/CVE-2005-1807/): Denial of service in n/a (medium 5.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2007-3215 and fix it if it is affected.

What it is: CVE-2007-3215 is a medium-severity command injection vulnerability in n/a, published on 14 Jun 2007. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2007-3215 in the wild and no public exploit code.

Affected packages and fixed versions:
- phpmailer/phpmailer (Packagist): affected all versions; fixed in 1.7.4
- phpmailer/phpmailer (Packagist): affected all versions; fixed in 1.7.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2007-3215/ (Markdown: https://insights.sbomify.com/CVE-2007-3215/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2007-3215
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2007-3215
- OSV: https://osv.dev/vulnerability/CVE-2007-3215

---
From sbomify Insights: https://insights.sbomify.com/CVE-2007-3215/
Summaries are generated and may contain mistakes; the official description above is the record.
