{"answers":{"affected":"2 open source packages ship an affected version, including rails. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2007-3227 exists.","fix":"Upgrade rails to 1.2.5 or later.","what":"CVE-2007-3227 is a medium-severity cross-site scripting vulnerability in Rubyonrails Rails, published on 14 Jun 2007. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2007-3227 and fix it if it is affected.\n\nWhat it is: CVE-2007-3227 is a medium-severity cross-site scripting vulnerability in Rubyonrails Rails, published on 14 Jun 2007. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2007-3227 exists.\n\nAffected packages and fixed versions:\n- rails (RubyGems): affected all versions; fixed in 1.2.5\n- rails (RubyGems): affected all versions; fixed in 1.2.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2007-3227/ (Markdown: https://insights.sbomify.com/CVE-2007-3227/index.md)","id":"CVE-2007-3227","markdown":"https://insights.sbomify.com/CVE-2007-3227/index.md","name":"CVE-2007-3227","record":{"aliases":["DEBIAN-CVE-2007-3227","GHSA-gm25-fpmr-43fj"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby on Rails","requires_auth":"none","summary":"Remote attackers can inject arbitrary web script via input values in the to_json function, requiring user interaction to execute.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"rails","vendor":"rubyonrails"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:N/I:P/A:N","version":"2.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Cross-site scripting (XSS) vulnerability in the to_json (ActiveRecord::Base#to_json) function in Ruby on Rails before edge 9606 allows remote attackers to inject arbitrary web script via the input values.","ecosystems":["RubyGems"],"exploits":{"exploitdb":1,"first_seen":"2007-05-25","github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[{"date":"2007-05-25","kind":"exploitdb","ref":"30089","stars":null,"title":"Ruby on Rails 1.2.3 To_JSON - Script Injection"}],"tier":"weaponised"},"has_fix":true,"headline":"Moderate severity vulnerability that affects rails","id":"CVE-2007-3227","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":"rubyonrails:rails","products":["rubyonrails:rails"],"type":"xss","year":"2007"},"n_packages":2,"n_references":13,"next":{"headline":"Code injection in n/a","id":"CVE-2007-3228"},"packages":[{"ecosystem":"RubyGems","fixed":["1.2.5"],"introduced":["0"],"last_affected":[],"package":"rails","purl":null,"source":"GHSA-gm25-fpmr-43fj"},{"ecosystem":"RubyGems","fixed":["1.2.5"],"introduced":["0"],"last_affected":[],"package":"rails","purl":"pkg:gem/rails","source":"GHSA-gm25-fpmr-43fj"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2007-3226"},"products":["n/a"],"published":"2007-06-14","related":[{"cvss_score":10,"headline":"Active Record contains deserialization of arbitrary YAML","id":"CVE-2013-0277","kev_date_added":null,"published":"2013-02-13"},{"cvss_score":8.1,"headline":"SQL injection in n/a","id":"CVE-2017-17916","kev_date_added":null,"published":"2017-12-29"},{"cvss_score":8.1,"headline":"SQL injection in n/a","id":"CVE-2017-17917","kev_date_added":null,"published":"2017-12-29"},{"cvss_score":8,"headline":"Rails Active Storage has possible Path Traversal in DiskService","id":"CVE-2026-33195","kev_date_added":null,"published":"2026-03-23"},{"cvss_score":7.5,"headline":"Rails possible ReDoS vulnerability in Accept header parsing in Action Dispatch","id":"CVE-2024-26142","kev_date_added":null,"published":"2024-02-27"},{"cvss_score":7.5,"headline":"ReDoS based DoS vulnerability in Action Dispatch","id":"CVE-2023-22792","kev_date_added":null,"published":"2023-02-09"},{"cvss_score":7.5,"headline":"Denial of Service in Action Dispatch","id":"CVE-2021-22902","kev_date_added":null,"published":"2021-06-11"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-07","vendors":["n/a"]},"summary":"Remote attackers can inject arbitrary web script via input values in the to_json function, requiring user interaction to execute.","url":"https://insights.sbomify.com/CVE-2007-3227/"}