# CVE-2007-3227: Moderate severity vulnerability that affects rails

> Remote attackers can inject arbitrary web script via input values in the to_json function, requiring user interaction to execute.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 Jun 2007
- **Updated:** 7 Aug 2024
- **Also known as:** DEBIAN-CVE-2007-3227, GHSA-gm25-fpmr-43fj

## What is CVE-2007-3227?

CVE-2007-3227 is a medium-severity cross-site scripting vulnerability in Rubyonrails Rails, published on 14 Jun 2007. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cross-site scripting (XSS) vulnerability in the to_json (ActiveRecord::Base#to_json) function in Ruby on Rails before edge 9606 allows remote attackers to inject arbitrary web script via the input values.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2007-3227?

2 open source packages ship an affected version, including rails. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rails` | RubyGems | All versions | 1.2.5 |
| `rails` | RubyGems | All versions | 1.2.5 |

Products: Rubyonrails Rails.

## How do I fix CVE-2007-3227?

Upgrade rails to 1.2.5 or later.

## Is CVE-2007-3227 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2007-3227 exists.

Public exploit code:

- Ruby on Rails 1.2.3 To_JSON - Script Injection (exploitdb)

## Other vulnerabilities in Rubyonrails Rails

- [CVE-2013-0277](https://insights.sbomify.com/CVE-2013-0277/): Active Record contains deserialization of arbitrary YAML (critical 10.0)
- [CVE-2017-17916](https://insights.sbomify.com/CVE-2017-17916/): SQL injection in n/a (high 8.1)
- [CVE-2017-17917](https://insights.sbomify.com/CVE-2017-17917/): SQL injection in n/a (high 8.1)
- [CVE-2026-33195](https://insights.sbomify.com/CVE-2026-33195/): Rails Active Storage has possible Path Traversal in DiskService (high 8.0)
- [CVE-2024-26142](https://insights.sbomify.com/CVE-2024-26142/): Rails possible ReDoS vulnerability in Accept header parsing in Action Dispatch (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2007-3227 and fix it if it is affected.

What it is: CVE-2007-3227 is a medium-severity cross-site scripting vulnerability in Rubyonrails Rails, published on 14 Jun 2007. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2007-3227 exists.

Affected packages and fixed versions:
- rails (RubyGems): affected all versions; fixed in 1.2.5
- rails (RubyGems): affected all versions; fixed in 1.2.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2007-3227/ (Markdown: https://insights.sbomify.com/CVE-2007-3227/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2007-3227
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2007-3227
- OSV: https://osv.dev/vulnerability/CVE-2007-3227

---
From sbomify Insights: https://insights.sbomify.com/CVE-2007-3227/
Summaries are generated and may contain mistakes; the official description above is the record.
