# CVE-2007-5333: Exposure of Sensitive Information in Apache Tomcat

> Apache Tomcat fails to sanitize cookie values, allowing remote attackers to steal session IDs and hijack user sessions.

- **Severity:** Medium 5.0 (`AV:N/AC:L/Au:N/C:P/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Feb 2008
- **Updated:** 7 Aug 2024
- **Also known as:** GHSA-cww4-vj5r-rx57

## What is CVE-2007-5333?

CVE-2007-5333 is a medium-severity vulnerability in Apache Tomcat, published on 12 Feb 2008. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Apache Tomcat 6.0.0 through 6.0.14, 5.5.0 through 5.5.25, and 4.1.0 through 4.1.36 does not properly handle (1) double quote (") characters or (2) %5C (encoded backslash) sequences in a cookie value, which might cause sensitive information such as session IDs to be leaked to remote attackers and enable session hijacking attacks.  NOTE: this issue exists because of an incomplete fix for CVE-2007-3385.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2007-5333?

6 open source packages ship an affected version, including org.apache.tomcat:tomcat. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.tomcat:tomcat` | Maven | From 4.1.0 | 4.1.37 |
| `org.apache.tomcat:tomcat` | Maven | From 4.1.0 | 4.1.37 |
| `org.apache.tomcat:tomcat` | Maven | From 5.5.0 | 5.5.26 |
| `org.apache.tomcat:tomcat` | Maven | From 5.5.0 | 5.5.26 |
| `org.apache.tomcat:tomcat` | Maven | From 6.0.0 | 6.0.15 |
| `org.apache.tomcat:tomcat` | Maven | From 6.0.0 | 6.0.15 |

Products: Apache Tomcat.

## How do I fix CVE-2007-5333?

Upgrade org.apache.tomcat:tomcat to a fixed version for your release line: 4.1.37, 5.5.26 or 6.0.15.

## Is CVE-2007-5333 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2007-5333 exists.

Public exploit code:

- Apache Tomcat 6.0.15 - Cookie Quote Handling Remote Information Disclosure (exploitdb)

## Other vulnerabilities in Apache Tomcat

- [CVE-2025-24813](https://insights.sbomify.com/CVE-2025-24813/): Apache Tomcat Path Equivalence (critical 10.0, exploited in the wild)
- [CVE-2016-8735](https://insights.sbomify.com/CVE-2016-8735/): Apache Tomcat Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2017-12617](https://insights.sbomify.com/CVE-2017-12617/): Apache Tomcat Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2017-12615](https://insights.sbomify.com/CVE-2017-12615/): Apache Tomcat on Windows Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2026-34486](https://insights.sbomify.com/CVE-2026-34486/): Apache Tomcat Missing Encryption of Sensitive Data (high 7.5, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2007-5333 and fix it if it is affected.

What it is: CVE-2007-5333 is a medium-severity vulnerability in Apache Tomcat, published on 12 Feb 2008. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2007-5333 exists.

Affected packages and fixed versions:
- org.apache.tomcat:tomcat (Maven): affected from 4.1.0; fixed in 4.1.37
- org.apache.tomcat:tomcat (Maven): affected from 4.1.0; fixed in 4.1.37
- org.apache.tomcat:tomcat (Maven): affected from 5.5.0; fixed in 5.5.26
- org.apache.tomcat:tomcat (Maven): affected from 5.5.0; fixed in 5.5.26
- org.apache.tomcat:tomcat (Maven): affected from 6.0.0; fixed in 6.0.15
- org.apache.tomcat:tomcat (Maven): affected from 6.0.0; fixed in 6.0.15

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2007-5333/ (Markdown: https://insights.sbomify.com/CVE-2007-5333/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2007-5333
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2007-5333
- OSV: https://osv.dev/vulnerability/CVE-2007-5333

---
From sbomify Insights: https://insights.sbomify.com/CVE-2007-5333/
Summaries are generated and may contain mistakes; the official description above is the record.
