# CVE-2007-5379: Moderate severity vulnerability that affects rails

> Remote attackers can read arbitrary XML files and determine file existence via unsafe XML parsing in Ruby on Rails.

- **Severity:** Medium 5.0 (`AV:N/AC:L/Au:N/C:P/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Oct 2007
- **Updated:** 7 Aug 2024
- **Also known as:** DEBIAN-CVE-2007-5379, GHSA-fjfg-q662-gm6j

## What is CVE-2007-5379?

CVE-2007-5379 is a medium-severity vulnerability in n/a, published on 19 Oct 2007. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Rails before 1.2.4, as used for Ruby on Rails, allows remote attackers and ActiveResource servers to determine the existence of arbitrary files and read arbitrary XML files via the Hash.from_xml (Hash#from_xml) method, which uses XmlSimple (XML::Simple) unsafely, as demonstrated by reading passwords from the Pidgin (Gaim) .purple/accounts.xml file.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2007-5379?

2 open source packages ship an affected version, including rails. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rails` | RubyGems | All versions | 1.2.4 |
| `rails` | RubyGems | All versions | 1.2.4 |

Products: David Hansson Ruby on Rails.

## How do I fix CVE-2007-5379?

Upgrade rails to 1.2.4 or later.

## Is CVE-2007-5379 being exploited?

There is no known exploitation of CVE-2007-5379 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2007-5380](https://insights.sbomify.com/CVE-2007-5380/): Session fixation vulnerability in Rails (medium 6.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2007-5379 and fix it if it is affected.

What it is: CVE-2007-5379 is a medium-severity vulnerability in n/a, published on 19 Oct 2007. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2007-5379 in the wild and no public exploit code.

Affected packages and fixed versions:
- rails (RubyGems): affected all versions; fixed in 1.2.4
- rails (RubyGems): affected all versions; fixed in 1.2.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2007-5379/ (Markdown: https://insights.sbomify.com/CVE-2007-5379/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2007-5379
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2007-5379
- OSV: https://osv.dev/vulnerability/CVE-2007-5379

---
From sbomify Insights: https://insights.sbomify.com/CVE-2007-5379/
Summaries are generated and may contain mistakes; the official description above is the record.
