{"answers":{"affected":"2 open source packages ship an affected version, including org.mortbay.jetty:jetty. It affects 1 product.","exploited":"There is no known exploitation of CVE-2007-5614 in the wild and no public exploit code.","fix":"Upgrade org.mortbay.jetty:jetty to 6.1.6 or later.","what":"CVE-2007-5614 is a high-severity vulnerability in n/a, published on 5 Dec 2007. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2007-5614 and fix it if it is affected.\n\nWhat it is: CVE-2007-5614 is a high-severity vulnerability in n/a, published on 5 Dec 2007. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2007-5614 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.mortbay.jetty:jetty (Maven): affected all versions; fixed in 6.1.6\n- org.mortbay.jetty:jetty (Maven): affected all versions; fixed in 6.1.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2007-5614/ (Markdown: https://insights.sbomify.com/CVE-2007-5614/index.md)","id":"CVE-2007-5614","markdown":"https://insights.sbomify.com/CVE-2007-5614/index.md","name":"CVE-2007-5614","record":{"aliases":["GHSA-fvh3-4v5r-cvvc"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Jetty web server","requires_auth":"none","summary":"Remote attackers can hijack browser sessions by exploiting improper handling of quote sequences in HTML cookie parameters in Mortbay Jetty.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"certcc","cpe":[{"product":"jetty","vendor":"mortbay_jetty"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"AV:N/AC:L/Au:N/C:P/I:P/A:P","version":"2.0"},"cwes":[],"description":"Mortbay Jetty before 6.1.6rc1 does not properly handle \"certain quote sequences\" in HTML cookie parameters, which allows remote attackers to hijack browser sessions via unspecified vectors.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Improper Authentication in Mortbay Jetty","id":"CVE-2007-5614","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"other","year":"2007"},"n_packages":2,"n_references":9,"next":{"headline":"Mortbay Jetty CRLF Injection Vulnerability","id":"CVE-2007-5615"},"packages":[{"ecosystem":"Maven","fixed":["6.1.6"],"introduced":["0"],"last_affected":[],"package":"org.mortbay.jetty:jetty","purl":null,"source":"GHSA-fvh3-4v5r-cvvc"},{"ecosystem":"Maven","fixed":["6.1.6"],"introduced":["0"],"last_affected":[],"package":"org.mortbay.jetty:jetty","purl":"pkg:maven/org.mortbay.jetty/jetty","source":"GHSA-fvh3-4v5r-cvvc"}],"prev":{"headline":"Mortbay Jetty vulnerable to Cross-site scripting","id":"CVE-2007-5613"},"products":["n/a"],"published":"2007-12-05","related":[{"cvss_score":5,"headline":"Mortbay Jetty Double Slash URI Information Disclosure Vulnerability","id":"CVE-2007-6672","kev_date_added":null,"published":"2008-01-08"},{"cvss_score":5,"headline":"Mortbay Jetty CRLF Injection Vulnerability","id":"CVE-2007-5615","kev_date_added":null,"published":"2007-12-05"},{"cvss_score":4.3,"headline":"Mortbay Jetty vulnerable to Cross-site scripting","id":"CVE-2007-5613","kev_date_added":null,"published":"2007-12-05"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-07","vendors":["n/a"]},"summary":"Remote attackers can hijack browser sessions by exploiting improper handling of quote sequences in HTML cookie parameters in Mortbay Jetty.","url":"https://insights.sbomify.com/CVE-2007-5614/"}