{"answers":{"affected":"2 open source packages ship an affected version, including rails. It affects 1 product.","exploited":"There is no known exploitation of CVE-2007-6077 in the wild and no public exploit code.","fix":"Upgrade rails to 1.2.6 or later.","what":"CVE-2007-6077 is a medium-severity authentication bypass vulnerability in Rubyonrails Rails, published on 21 Nov 2007. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2007-6077 and fix it if it is affected.\n\nWhat it is: CVE-2007-6077 is a medium-severity authentication bypass vulnerability in Rubyonrails Rails, published on 21 Nov 2007. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2007-6077 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- rails (RubyGems): affected all versions; fixed in 1.2.6\n- rails (RubyGems): affected all versions; fixed in 1.2.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2007-6077/ (Markdown: https://insights.sbomify.com/CVE-2007-6077/index.md)","id":"CVE-2007-6077","markdown":"https://insights.sbomify.com/CVE-2007-6077/index.md","name":"CVE-2007-6077","record":{"aliases":["DEBIAN-CVE-2007-6077","GHSA-p4c6-77gc-694x"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby on Rails","requires_auth":"none","summary":"Remote attackers can hijack user sessions due to flawed session fixation protection in Ruby on Rails, requiring user interaction to exploit.","user_interaction":"required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"rails","vendor":"rubyonrails"}],"cvss":{"score":6.8,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:P/I:P/A:P","version":"2.0"},"cwes":[{"id":"CWE-362","name":"Concurrent Execution using Shared Resource with Improper Synchronization"}],"description":"The session fixation protection mechanism in cgi_process.rb in Rails 1.2.4, as used in Ruby on Rails, removes the :cookie_only attribute from the DEFAULT_SESSION_OPTIONS constant, which effectively causes cookie_only to be applied only to the first instantiation of CgiRequest, which allows remote attackers to conduct session fixation attacks.  NOTE: this is due to an incomplete fix for CVE-2007-5380.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"session fixation protection mechanism in cgi_process.rb in Rails","id":"CVE-2007-6077","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":"rubyonrails:rails","products":["rubyonrails:rails"],"type":"auth_bypass","year":"2007"},"n_packages":2,"n_references":11,"next":{"headline":"SQL injection in n/a","id":"CVE-2007-6078"},"packages":[{"ecosystem":"RubyGems","fixed":["1.2.6"],"introduced":["0"],"last_affected":[],"package":"rails","purl":null,"source":"GHSA-p4c6-77gc-694x"},{"ecosystem":"RubyGems","fixed":["1.2.6"],"introduced":["0"],"last_affected":[],"package":"rails","purl":"pkg:gem/rails","source":"GHSA-p4c6-77gc-694x"}],"prev":{"headline":"Denial of service in n/a","id":"CVE-2007-6067"},"products":["n/a"],"published":"2007-11-21","related":[{"cvss_score":10,"headline":"Active Record contains deserialization of arbitrary YAML","id":"CVE-2013-0277","kev_date_added":null,"published":"2013-02-13"},{"cvss_score":8.1,"headline":"SQL injection in n/a","id":"CVE-2017-17916","kev_date_added":null,"published":"2017-12-29"},{"cvss_score":8.1,"headline":"SQL injection in n/a","id":"CVE-2017-17917","kev_date_added":null,"published":"2017-12-29"},{"cvss_score":8,"headline":"Rails Active Storage has possible Path Traversal in DiskService","id":"CVE-2026-33195","kev_date_added":null,"published":"2026-03-23"},{"cvss_score":7.5,"headline":"Rails possible ReDoS vulnerability in Accept header parsing in Action Dispatch","id":"CVE-2024-26142","kev_date_added":null,"published":"2024-02-27"},{"cvss_score":7.5,"headline":"ReDoS based DoS vulnerability in Action Dispatch","id":"CVE-2023-22792","kev_date_added":null,"published":"2023-02-09"},{"cvss_score":7.5,"headline":"Denial of Service in Action Dispatch","id":"CVE-2021-22902","kev_date_added":null,"published":"2021-06-11"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-07","vendors":["n/a"]},"summary":"Remote attackers can hijack user sessions due to flawed session fixation protection in Ruby on Rails, requiring user interaction to exploit.","url":"https://insights.sbomify.com/CVE-2007-6077/"}