# CVE-2007-6077: session fixation protection mechanism in cgi_process.rb in Rails

> Remote attackers can hijack user sessions due to flawed session fixation protection in Ruby on Rails, requiring user interaction to exploit.

- **Severity:** Medium 6.8 (`AV:N/AC:M/Au:N/C:P/I:P/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 21 Nov 2007
- **Updated:** 7 Aug 2024
- **Also known as:** DEBIAN-CVE-2007-6077, GHSA-p4c6-77gc-694x

## What is CVE-2007-6077?

CVE-2007-6077 is a medium-severity authentication bypass vulnerability in Rubyonrails Rails, published on 21 Nov 2007. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The session fixation protection mechanism in cgi_process.rb in Rails 1.2.4, as used in Ruby on Rails, removes the :cookie_only attribute from the DEFAULT_SESSION_OPTIONS constant, which effectively causes cookie_only to be applied only to the first instantiation of CgiRequest, which allows remote attackers to conduct session fixation attacks.  NOTE: this is due to an incomplete fix for CVE-2007-5380.

Weakness: CWE-362 (Concurrent Execution using Shared Resource with Improper Synchronization)

## Which versions are affected by CVE-2007-6077?

2 open source packages ship an affected version, including rails. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `rails` | RubyGems | All versions | 1.2.6 |
| `rails` | RubyGems | All versions | 1.2.6 |

Products: Rubyonrails Rails.

## How do I fix CVE-2007-6077?

Upgrade rails to 1.2.6 or later.

## Is CVE-2007-6077 being exploited?

There is no known exploitation of CVE-2007-6077 in the wild and no public exploit code.

## Other vulnerabilities in Rubyonrails Rails

- [CVE-2013-0277](https://insights.sbomify.com/CVE-2013-0277/): Active Record contains deserialization of arbitrary YAML (critical 10.0)
- [CVE-2017-17916](https://insights.sbomify.com/CVE-2017-17916/): SQL injection in n/a (high 8.1)
- [CVE-2017-17917](https://insights.sbomify.com/CVE-2017-17917/): SQL injection in n/a (high 8.1)
- [CVE-2026-33195](https://insights.sbomify.com/CVE-2026-33195/): Rails Active Storage has possible Path Traversal in DiskService (high 8.0)
- [CVE-2024-26142](https://insights.sbomify.com/CVE-2024-26142/): Rails possible ReDoS vulnerability in Accept header parsing in Action Dispatch (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2007-6077 and fix it if it is affected.

What it is: CVE-2007-6077 is a medium-severity authentication bypass vulnerability in Rubyonrails Rails, published on 21 Nov 2007. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2007-6077 in the wild and no public exploit code.

Affected packages and fixed versions:
- rails (RubyGems): affected all versions; fixed in 1.2.6
- rails (RubyGems): affected all versions; fixed in 1.2.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2007-6077/ (Markdown: https://insights.sbomify.com/CVE-2007-6077/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2007-6077
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2007-6077
- OSV: https://osv.dev/vulnerability/CVE-2007-6077

---
From sbomify Insights: https://insights.sbomify.com/CVE-2007-6077/
Summaries are generated and may contain mistakes; the official description above is the record.
