{"answers":{"affected":"2 open source packages ship an affected version, including gtk2. It affects 1 product.","exploited":"There is no known exploitation of CVE-2007-6183 in the wild and no public exploit code.","fix":"Upgrade gtk2 to 0.17.0 or later.","what":"CVE-2007-6183 is a medium-severity vulnerability in n/a, published on 30 Nov 2007."},"fix_prompt":"Check this codebase for CVE-2007-6183 and fix it if it is affected.\n\nWhat it is: CVE-2007-6183 is a medium-severity vulnerability in n/a, published on 30 Nov 2007. \nExploitation: There is no known exploitation of CVE-2007-6183 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- gtk2 (RubyGems): affected all versions; fixed in 0.17.0\n- gtk2 (RubyGems): affected all versions; fixed in 0.17.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2007-6183/ (Markdown: https://insights.sbomify.com/CVE-2007-6183/index.md)","id":"CVE-2007-6183","markdown":"https://insights.sbomify.com/CVE-2007-6183/index.md","name":"CVE-2007-6183","record":{"aliases":["DSA-1431-1","DTSA-102-1","GHSA-xgj6-pgrm-x4r2"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"unknown","non_default_config":false,"product_category":"Ruby GNOME bindings","requires_auth":"none","summary":"Attackers can execute arbitrary code via format string specifiers in the message parameter of Ruby-GNOME 2 message dialogs.","user_interaction":"required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"ruby_gnome2","vendor":"ruby_gnome2"}],"cvss":{"score":6.8,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:P/I:P/A:P","version":"2.0"},"cwes":[{"id":"CWE-134","name":"Use of Externally-Controlled Format String"}],"description":"Format string vulnerability in the mdiag_initialize function in gtk/src/rbgtkmessagedialog.c in Ruby-GNOME 2 (aka Ruby/Gnome2) 0.16.0, and SVN versions before 20071127, allows context-dependent attackers to execute arbitrary code via format string specifiers in the message parameter.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"gtk2 vulnerable to Use of Externally-Controlled Format String","id":"CVE-2007-6183","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"other","year":"2007"},"n_packages":2,"n_references":20,"next":{"headline":"Path traversal in n/a","id":"CVE-2007-6184"},"packages":[{"ecosystem":"RubyGems","fixed":["0.17.0"],"introduced":["0"],"last_affected":[],"package":"gtk2","purl":null,"source":"GHSA-xgj6-pgrm-x4r2"},{"ecosystem":"RubyGems","fixed":["0.17.0"],"introduced":["0"],"last_affected":[],"package":"gtk2","purl":"pkg:gem/gtk2","source":"GHSA-xgj6-pgrm-x4r2"}],"prev":{"headline":"Command injection in n/a","id":"CVE-2007-6182"},"products":["n/a"],"published":"2007-11-30","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-07","vendors":["n/a"]},"summary":"Attackers can execute arbitrary code via format string specifiers in the message parameter of Ruby-GNOME 2 message dialogs.","url":"https://insights.sbomify.com/CVE-2007-6183/"}