CVE-2007-6612 Mongrel vulnerable to directory traversal via double-encoded sequences
Remote attackers can read arbitrary files on the server via double-encoded directory traversal sequences in Mongrel.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2007-6612?
CVE-2007-6612 is a medium-severity path traversal vulnerability in n/a, published on 3 Jan 2008. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Directory traversal vulnerability in DirHandler (lib/mongrel/handlers.rb) in Mongrel 1.0.4 and 1.1.x before 1.1.3 allows remote attackers to read arbitrary files via an HTTP request containing double-encoded sequences (".%252e").
Weakness: CWE-22
Which versions are affected by CVE-2007-6612?
4 open source packages ship an affected version, including mongrel. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
mongrel RubyGems | From 1.0.4 | 1.0.5 |
mongrel RubyGems | From 1.0.4 | 1.0.5 |
mongrel RubyGems | From 1.1.0 | 1.1.3 |
mongrel RubyGems | From 1.1.0 | 1.1.3 |
Products include Mongrel Mongrel.
How do I fix CVE-2007-6612?
Upgrade mongrel to a fixed version for your release line: 1.0.5 or 1.1.3.
Upgrade, and resolve every user-supplied path against an allowed base folder before opening it. More about Path traversal.
Is CVE-2007-6612 being exploited?
There is no known exploitation of CVE-2007-6612 in the wild and no public exploit code.
Sources
Also known as GHSA-m7r6-43v2-49vf.