{"answers":{"affected":"4 open source packages ship an affected version, including mongrel. It affects 1 product.","exploited":"There is no known exploitation of CVE-2007-6612 in the wild and no public exploit code.","fix":"Upgrade mongrel to a fixed version for your release line: 1.0.5 or 1.1.3.","what":"CVE-2007-6612 is a medium-severity path traversal vulnerability in n/a, published on 3 Jan 2008. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2007-6612 and fix it if it is affected.\n\nWhat it is: CVE-2007-6612 is a medium-severity path traversal vulnerability in n/a, published on 3 Jan 2008. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2007-6612 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- mongrel (RubyGems): affected from 1.0.4; fixed in 1.0.5\n- mongrel (RubyGems): affected from 1.0.4; fixed in 1.0.5\n- mongrel (RubyGems): affected from 1.1.0; fixed in 1.1.3\n- mongrel (RubyGems): affected from 1.1.0; fixed in 1.1.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2007-6612/ (Markdown: https://insights.sbomify.com/CVE-2007-6612/index.md)","id":"CVE-2007-6612","markdown":"https://insights.sbomify.com/CVE-2007-6612/index.md","name":"CVE-2007-6612","record":{"aliases":["GHSA-m7r6-43v2-49vf"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby web server","requires_auth":"none","summary":"Remote attackers can read arbitrary files on the server via double-encoded directory traversal sequences in Mongrel.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"mongrel","vendor":"mongrel"}],"cvss":{"score":6.4,"severity":"medium","source":"nvd","vector":"AV:N/AC:L/Au:N/C:P/I:P/A:N","version":"2.0"},"cwes":[{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"Directory traversal vulnerability in DirHandler (lib/mongrel/handlers.rb) in Mongrel 1.0.4 and 1.1.x before 1.1.3 allows remote attackers to read arbitrary files via an HTTP request containing double-encoded sequences (\".%252e\").","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Mongrel vulnerable to directory traversal via double-encoded sequences","id":"CVE-2007-6612","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"path_traversal","year":"2007"},"n_packages":4,"n_references":12,"next":{"headline":"Memory corruption in n/a","id":"CVE-2007-6613"},"packages":[{"ecosystem":"RubyGems","fixed":["1.0.5"],"introduced":["1.0.4"],"last_affected":[],"package":"mongrel","purl":null,"source":"GHSA-m7r6-43v2-49vf"},{"ecosystem":"RubyGems","fixed":["1.0.5"],"introduced":["1.0.4"],"last_affected":[],"package":"mongrel","purl":"pkg:gem/mongrel","source":"GHSA-m7r6-43v2-49vf"},{"ecosystem":"RubyGems","fixed":["1.1.3"],"introduced":["1.1.0"],"last_affected":[],"package":"mongrel","purl":null,"source":"GHSA-m7r6-43v2-49vf"},{"ecosystem":"RubyGems","fixed":["1.1.3"],"introduced":["1.1.0"],"last_affected":[],"package":"mongrel","purl":"pkg:gem/mongrel","source":"GHSA-m7r6-43v2-49vf"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2007-6611"},"products":["n/a"],"published":"2008-01-03","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-07","vendors":["n/a"]},"summary":"Remote attackers can read arbitrary files on the server via double-encoded directory traversal sequences in Mongrel.","url":"https://insights.sbomify.com/CVE-2007-6612/"}