# CVE-2007-6672: Mortbay Jetty Double Slash URI Information Disclosure Vulnerability

> Remote attackers can bypass protections and read source files in Mortbay Jetty by using multiple slashes in the URI.

- **Severity:** Medium 5.0 (`AV:N/AC:L/Au:N/C:P/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Jan 2008
- **Updated:** 7 Aug 2024
- **Also known as:** GHSA-4jjw-xrr6-9v3p

## What is CVE-2007-6672?

CVE-2007-6672 is a medium-severity path traversal vulnerability in n/a, published on 8 Jan 2008. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Mortbay Jetty 6.1.5 and 6.1.6 allows remote attackers to bypass protection mechanisms and read the source of files via multiple '/' (slash) characters in the URI.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2007-6672?

2 open source packages ship an affected version, including org.mortbay.jetty:jetty. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.mortbay.jetty:jetty` | Maven | From 6.1.5 | 6.1.7 |
| `org.mortbay.jetty:jetty` | Maven | From 6.1.5 | 6.1.7 |

Products: Mortbay Jetty Jetty.

## How do I fix CVE-2007-6672?

Upgrade org.mortbay.jetty:jetty to 6.1.7 or later.

## Is CVE-2007-6672 being exploited?

There is no known exploitation of CVE-2007-6672 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2007-5614](https://insights.sbomify.com/CVE-2007-5614/): Improper Authentication in Mortbay Jetty (high 7.5)
- [CVE-2007-5615](https://insights.sbomify.com/CVE-2007-5615/): Mortbay Jetty CRLF Injection Vulnerability (medium 5.0)
- [CVE-2007-5613](https://insights.sbomify.com/CVE-2007-5613/): Mortbay Jetty vulnerable to Cross-site scripting (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2007-6672 and fix it if it is affected.

What it is: CVE-2007-6672 is a medium-severity path traversal vulnerability in n/a, published on 8 Jan 2008. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2007-6672 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.mortbay.jetty:jetty (Maven): affected from 6.1.5; fixed in 6.1.7
- org.mortbay.jetty:jetty (Maven): affected from 6.1.5; fixed in 6.1.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2007-6672/ (Markdown: https://insights.sbomify.com/CVE-2007-6672/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2007-6672
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2007-6672
- OSV: https://osv.dev/vulnerability/CVE-2007-6672

---
From sbomify Insights: https://insights.sbomify.com/CVE-2007-6672/
Summaries are generated and may contain mistakes; the official description above is the record.
