# CVE-2007-6738: pyftpdlib Use of Insufficiently Random Values of port selection on PASV command

> Remote attackers can infer the number of active data connections by observing predictable PASV port responses in pyftpdlib.

- **Severity:** Medium 5.0 (`AV:N/AC:L/Au:N/C:P/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Oct 2010
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-gh7c-cg3x-pmcr, PYSEC-2010-22

## What is CVE-2007-6738?

CVE-2007-6738 is a medium-severity vulnerability in n/a, published on 19 Oct 2010. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

pyftpdlib before 0.1.1 does not choose a random value for the port associated with the PASV command, which makes it easier for remote attackers to obtain potentially sensitive information about the number of in-progress data connections by reading the response to this command.

## Which versions are affected by CVE-2007-6738?

3 open source packages ship an affected version, including pyftpdlib. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pyftpdlib` | PyPI | All versions | 0.1.1 |
| `pyftpdlib` | PyPI | All versions | 0.1.1 |
| `pyftpdlib` | PyPI | All versions | 0.1.1 |

Products: G.rodola Pyftpdlib.

## How do I fix CVE-2007-6738?

Upgrade pyftpdlib to 0.1.1 or later.

## Is CVE-2007-6738 being exploited?

There is no known exploitation of CVE-2007-6738 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2007-6737](https://insights.sbomify.com/CVE-2007-6737/): Improper Authentication in pyftpdlib (high 7.5)
- [CVE-2008-7263](https://insights.sbomify.com/CVE-2008-7263/): Improper Authentication in pyftpdlib (high 7.5)
- [CVE-2007-6736](https://insights.sbomify.com/CVE-2007-6736/): Directory Traversal in pyftpdlib (medium 6.5)
- [CVE-2007-6741](https://insights.sbomify.com/CVE-2007-6741/): Improper privilege management in pyftpdlib (medium 6.5)
- [CVE-2008-7262](https://insights.sbomify.com/CVE-2008-7262/): Directory traversal in pyftpdlib (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2007-6738 and fix it if it is affected.

What it is: CVE-2007-6738 is a medium-severity vulnerability in n/a, published on 19 Oct 2010. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2007-6738 in the wild and no public exploit code.

Affected packages and fixed versions:
- pyftpdlib (PyPI): affected all versions; fixed in 0.1.1
- pyftpdlib (PyPI): affected all versions; fixed in 0.1.1
- pyftpdlib (PyPI): affected all versions; fixed in 0.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2007-6738/ (Markdown: https://insights.sbomify.com/CVE-2007-6738/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2007-6738
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2007-6738
- OSV: https://osv.dev/vulnerability/CVE-2007-6738

---
From sbomify Insights: https://insights.sbomify.com/CVE-2007-6738/
Summaries are generated and may contain mistakes; the official description above is the record.
