# CVE-2008-0164: Plone Cross-site request forgery (CSRF)

> Remote attackers can exploit CSRF flaws in Plone CMS to add arbitrary accounts or modify group privileges, requiring victim interaction.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 20 Mar 2008
- **Updated:** 7 Aug 2024
- **Also known as:** GHSA-4j3w-g62x-hrcp, PYSEC-2008-14

## What is CVE-2008-0164?

CVE-2008-0164 is a medium-severity vulnerability in n/a, published on 20 Mar 2008. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Multiple cross-site request forgery (CSRF) vulnerabilities in Plone CMS 3.0.5 and 3.0.6 allow remote attackers to (1) add arbitrary accounts via the join_form page and (2) change the privileges of arbitrary groups via the prefs_groups_overview page.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2008-0164?

3 open source packages ship an affected version, including plone and Plone. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `plone` | PyPI | All versions | 3.1 |
| `plone` | PyPI | All versions | 3.1 |
| `Plone` | PyPI | All versions | 3.1 |

Products: Plone Plone Cms.

## How do I fix CVE-2008-0164?

Upgrade plone to 3.1 or later.

## Is CVE-2008-0164 being exploited?

There is no known exploitation of CVE-2008-0164 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2008-1393](https://insights.sbomify.com/CVE-2008-1393/): Plone Improper Session Management (critical 10.0)
- [CVE-2008-1394](https://insights.sbomify.com/CVE-2008-1394/): Plone CMS Improper Session Management (high 7.5)
- [CVE-2008-1395](https://insights.sbomify.com/CVE-2008-1395/): Auth bypass in n/a (high 7.5)
- [CVE-2008-1396](https://insights.sbomify.com/CVE-2008-1396/): Plone credentials stored in session cookie (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2008-0164 and fix it if it is affected.

What it is: CVE-2008-0164 is a medium-severity vulnerability in n/a, published on 20 Mar 2008. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2008-0164 in the wild and no public exploit code.

Affected packages and fixed versions:
- plone (PyPI): affected all versions; fixed in 3.1
- plone (PyPI): affected all versions; fixed in 3.1
- Plone (PyPI): affected all versions; fixed in 3.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2008-0164/ (Markdown: https://insights.sbomify.com/CVE-2008-0164/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2008-0164
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2008-0164
- OSV: https://osv.dev/vulnerability/CVE-2008-0164

---
From sbomify Insights: https://insights.sbomify.com/CVE-2008-0164/
Summaries are generated and may contain mistakes; the official description above is the record.
