# CVE-2008-1393: Plone Improper Session Management

> Remote attackers can sniff network traffic to decode admin credentials from cookies, leading to administrative privilege escalation in Plone CMS.

- **Severity:** Critical 10.0 (`AV:N/AC:L/Au:N/C:C/I:C/A:C`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Mar 2008
- **Updated:** 7 Aug 2024
- **Also known as:** GHSA-593c-j348-f3gv, PYSEC-2026-731

## What is CVE-2008-1393?

CVE-2008-1393 is a critical vulnerability in n/a, published on 20 Mar 2008. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Plone CMS 3.0.5, and probably other 3.x versions, places a base64 encoded form of the username and password in the __ac cookie for the admin account, which makes it easier for remote attackers to obtain administrative privileges by sniffing the network.

Weakness: CWE-255

## Which versions are affected by CVE-2008-1393?

3 open source packages ship an affected version, including plone and Plone. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `plone` | PyPI | All versions | 3.0 |
| `plone` | PyPI | All versions | 3.0 |
| `Plone` | PyPI | All versions | 3.0 |

Products: Plone Plone Cms.

## How do I fix CVE-2008-1393?

Upgrade plone to 3.0 or later.

## Is CVE-2008-1393 being exploited?

There is no known exploitation of CVE-2008-1393 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2008-1394](https://insights.sbomify.com/CVE-2008-1394/): Plone CMS Improper Session Management (high 7.5)
- [CVE-2008-1395](https://insights.sbomify.com/CVE-2008-1395/): Auth bypass in n/a (high 7.5)
- [CVE-2008-0164](https://insights.sbomify.com/CVE-2008-0164/): Plone Cross-site request forgery (CSRF) (medium 4.3)
- [CVE-2008-1396](https://insights.sbomify.com/CVE-2008-1396/): Plone credentials stored in session cookie (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2008-1393 and fix it if it is affected.

What it is: CVE-2008-1393 is a critical vulnerability in n/a, published on 20 Mar 2008. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2008-1393 in the wild and no public exploit code.

Affected packages and fixed versions:
- plone (PyPI): affected all versions; fixed in 3.0
- plone (PyPI): affected all versions; fixed in 3.0
- Plone (PyPI): affected all versions; fixed in 3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2008-1393/ (Markdown: https://insights.sbomify.com/CVE-2008-1393/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2008-1393
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2008-1393
- OSV: https://osv.dev/vulnerability/CVE-2008-1393

---
From sbomify Insights: https://insights.sbomify.com/CVE-2008-1393/
Summaries are generated and may contain mistakes; the official description above is the record.
