{"answers":{"affected":"2 open source packages ship an affected version, including moodle/moodle. It affects 2 products.","exploited":"There is no known exploitation of CVE-2008-1502 in the wild and no public exploit code.","fix":"Upgrade moodle/moodle to 1.8.5 or later.","what":"CVE-2008-1502 is a medium-severity cross-site scripting vulnerability in Moodle Moodle, published on 25 Mar 2008. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2008-1502 and fix it if it is affected.\n\nWhat it is: CVE-2008-1502 is a medium-severity cross-site scripting vulnerability in Moodle Moodle, published on 25 Mar 2008. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2008-1502 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- moodle/moodle (Packagist): affected all versions; fixed in 1.8.5\n- moodle/moodle (Packagist): affected all versions; fixed in 1.8.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2008-1502/ (Markdown: https://insights.sbomify.com/CVE-2008-1502/index.md)","id":"CVE-2008-1502","markdown":"https://insights.sbomify.com/CVE-2008-1502/index.md","name":"CVE-2008-1502","record":{"aliases":["DEBIAN-CVE-2008-1502","GHSA-v759-3wr5-p294"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP HTML filtering library","requires_auth":"none","summary":"Remote attackers can bypass HTML filtering in the KSES library to conduct cross-site scripting attacks via crafted URL protocols.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"egroupware","vendor":"egroupware"},{"product":"moodle","vendor":"moodle"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:N/I:P/A:N","version":"2.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"The _bad_protocol_once function in phpgwapi/inc/class.kses.inc.php in KSES, as used in eGroupWare before 1.4.003, Moodle before 1.8.5, and other products, allows remote attackers to bypass HTML filtering and conduct cross-site scripting (XSS) attacks via a string containing crafted URL protocols.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Moodle vulnerable to Cross-site scripting","id":"CVE-2008-1502","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"moodle:moodle","products":["moodle:moodle"],"type":"xss","year":"2008"},"n_packages":2,"n_references":21,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2008-1503"},"packages":[{"ecosystem":"Packagist","fixed":["1.8.5"],"introduced":["0"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-v759-3wr5-p294"},{"ecosystem":"Packagist","fixed":["1.8.5"],"introduced":["0"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-v759-3wr5-p294"}],"prev":{"headline":"Denial of service in n/a","id":"CVE-2008-1501"},"products":["n/a"],"published":"2008-03-25","related":[{"cvss_score":10,"headline":"Code injection in n/a","id":"CVE-2008-2041","kev_date_added":null,"published":"2008-04-30"},{"cvss_score":10,"headline":"Unspecified vulnerability in Walter Zorn wz_tooltip.js (aka wz_tooltips) before 4.01, as used by eGroupWare before 1.2.107-2 and other packa","id":"CVE-2007-3154","kev_date_added":null,"published":"2007-06-11"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2007-3155","kev_date_added":null,"published":"2007-06-11"},{"cvss_score":8.7,"headline":"EGroupware has SQL Injection in Nextmatch Filter Processing","id":"CVE-2026-22243","kev_date_added":null,"published":"2026-01-28"},{"cvss_score":8.5,"headline":"Code injection in n/a","id":"CVE-2014-2988","kev_date_added":null,"published":"2014-10-27"},{"cvss_score":7.5,"headline":"Code injection in n/a","id":"CVE-2014-2027","kev_date_added":null,"published":"2015-03-31"},{"cvss_score":7.5,"headline":"SQL injection in n/a","id":"CVE-2011-4949","kev_date_added":null,"published":"2012-08-31"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-07","vendors":["n/a"]},"summary":"Remote attackers can bypass HTML filtering in the KSES library to conduct cross-site scripting attacks via crafted URL protocols.","url":"https://insights.sbomify.com/CVE-2008-1502/"}