{"answers":{"affected":"2 open source packages ship an affected version, including org.opencms:opencms-core. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2008-1510 exists.","fix":"Upgrade org.opencms:opencms-core to 7.0.4 or later.","what":"CVE-2008-1510 is a medium-severity cross-site scripting vulnerability in n/a, published on 25 Mar 2008. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2008-1510 and fix it if it is affected.\n\nWhat it is: CVE-2008-1510 is a medium-severity cross-site scripting vulnerability in n/a, published on 25 Mar 2008. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2008-1510 exists.\n\nAffected packages and fixed versions:\n- org.opencms:opencms-core (Maven): affected all versions; fixed in 7.0.4\n- org.opencms:opencms-core (Maven): affected all versions; fixed in 7.0.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2008-1510/ (Markdown: https://insights.sbomify.com/CVE-2008-1510/index.md)","id":"CVE-2008-1510","markdown":"https://insights.sbomify.com/CVE-2008-1510/index.md","name":"CVE-2008-1510","record":{"aliases":["GHSA-4fg8-5hwc-wg5v"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"OpenCMS","requires_auth":"high_privilege","summary":"Remote attackers can inject arbitrary web script or HTML via search parameters in the admin user list interface, potentially leading to session hijacking or malicious actions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"opencms","vendor":"alkacon"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:N/I:P/A:N","version":"2.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Cross-site scripting (XSS) vulnerability in system/workplace/admin/accounts/users_list.jsp in Alkacon OpenCMS 7.0.3 allows remote attackers to inject arbitrary web script or HTML via the (1) searchfilter or (2) listSearchFilter parameter.","ecosystems":["Maven"],"exploits":{"exploitdb":1,"first_seen":"2008-03-24","github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[{"date":"2008-03-24","kind":"exploitdb","ref":"31475","stars":null,"title":"Alkacon OpenCMS 7.0.3 - 'users_list.jsp' Multiple Cross-Site Scripting Vulnerabilities"}],"tier":"weaponised"},"has_fix":true,"headline":"Alkacon OpenCMS XSS via searchfilter or listSearchFilter parameter","id":"CVE-2008-1510","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2008"},"n_packages":2,"n_references":4,"next":{"headline":"Code injection in n/a","id":"CVE-2008-1511"},"packages":[{"ecosystem":"Maven","fixed":["7.0.4"],"introduced":["0"],"last_affected":[],"package":"org.opencms:opencms-core","purl":null,"source":"GHSA-4fg8-5hwc-wg5v"},{"ecosystem":"Maven","fixed":["7.0.4"],"introduced":["0"],"last_affected":[],"package":"org.opencms:opencms-core","purl":"pkg:maven/org.opencms/opencms-core","source":"GHSA-4fg8-5hwc-wg5v"}],"prev":{"headline":"SQL injection in n/a","id":"CVE-2008-1509"},"products":["n/a"],"published":"2008-03-25","related":[{"cvss_score":8.8,"headline":"Cross-site request forgery in n/a","id":"CVE-2018-8811","kev_date_added":null,"published":"2018-03-20"},{"cvss_score":7.8,"headline":"Alkacon OpenCMS CSV Injection via New User module","id":"CVE-2019-11819","kev_date_added":null,"published":"2019-05-08"},{"cvss_score":6.8,"headline":"Cross-site scripting in n/a","id":"CVE-2005-4475","kev_date_added":null,"published":"2005-12-22"},{"cvss_score":6.5,"headline":"OpenCMS Cross-Site Scripting vulnerability","id":"CVE-2024-42699","kev_date_added":null,"published":"2025-04-21"},{"cvss_score":6.5,"headline":"XML External Entity Reference in org.opencms:opencms-core","id":"CVE-2021-3312","kev_date_added":null,"published":"2021-10-08"},{"cvss_score":6.5,"headline":"Alkacon OpenCMS Improper Access Control via system/workplace/views/admin/admin-main.jsp","id":"CVE-2006-3935","kev_date_added":null,"published":"2006-07-31"},{"cvss_score":6.4,"headline":"Cross-Site Scripting stored in Alkacon OpenCMS","id":"CVE-2024-5520","kev_date_added":null,"published":"2024-05-30"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-07","vendors":["n/a"]},"summary":"Remote attackers can inject arbitrary web script or HTML via search parameters in the admin user list interface, potentially leading to session hijacking or malicious actions.","url":"https://insights.sbomify.com/CVE-2008-1510/"}