# CVE-2008-1510: Alkacon OpenCMS XSS via searchfilter or listSearchFilter parameter

> Remote attackers can inject arbitrary web script or HTML via search parameters in the admin user list interface, potentially leading to session hijacking or malicious actions.

- **Severity:** Medium 4.3 (`AV:N/AC:M/Au:N/C:N/I:P/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 Mar 2008
- **Updated:** 7 Aug 2024
- **Also known as:** GHSA-4fg8-5hwc-wg5v

## What is CVE-2008-1510?

CVE-2008-1510 is a medium-severity cross-site scripting vulnerability in n/a, published on 25 Mar 2008. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Cross-site scripting (XSS) vulnerability in system/workplace/admin/accounts/users_list.jsp in Alkacon OpenCMS 7.0.3 allows remote attackers to inject arbitrary web script or HTML via the (1) searchfilter or (2) listSearchFilter parameter.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2008-1510?

2 open source packages ship an affected version, including org.opencms:opencms-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.opencms:opencms-core` | Maven | All versions | 7.0.4 |
| `org.opencms:opencms-core` | Maven | All versions | 7.0.4 |

Products: Alkacon Opencms.

## How do I fix CVE-2008-1510?

Upgrade org.opencms:opencms-core to 7.0.4 or later.

## Is CVE-2008-1510 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2008-1510 exists.

Public exploit code:

- Alkacon OpenCMS 7.0.3 - 'users_list.jsp' Multiple Cross-Site Scripting Vulnerabilities (exploitdb)

## Other vulnerabilities in n/a

- [CVE-2018-8811](https://insights.sbomify.com/CVE-2018-8811/): Cross-site request forgery in n/a (high 8.8)
- [CVE-2019-11819](https://insights.sbomify.com/CVE-2019-11819/): Alkacon OpenCMS CSV Injection via New User module (high 7.8)
- [CVE-2005-4475](https://insights.sbomify.com/CVE-2005-4475/): Cross-site scripting in n/a (medium 6.8)
- [CVE-2024-42699](https://insights.sbomify.com/CVE-2024-42699/): OpenCMS Cross-Site Scripting vulnerability (medium 6.5)
- [CVE-2021-3312](https://insights.sbomify.com/CVE-2021-3312/): XML External Entity Reference in org.opencms:opencms-core (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2008-1510 and fix it if it is affected.

What it is: CVE-2008-1510 is a medium-severity cross-site scripting vulnerability in n/a, published on 25 Mar 2008. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2008-1510 exists.

Affected packages and fixed versions:
- org.opencms:opencms-core (Maven): affected all versions; fixed in 7.0.4
- org.opencms:opencms-core (Maven): affected all versions; fixed in 7.0.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2008-1510/ (Markdown: https://insights.sbomify.com/CVE-2008-1510/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2008-1510
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2008-1510
- OSV: https://osv.dev/vulnerability/CVE-2008-1510

---
From sbomify Insights: https://insights.sbomify.com/CVE-2008-1510/
Summaries are generated and may contain mistakes; the official description above is the record.
