# CVE-2008-1728: Ignite Realtime Openfire allows remote authenticated users to cause a denial of service

> Authenticated remote users can cause a denial of service in Openfire by triggering large outgoing queues without reading messages.

- **Severity:** Medium 4.0 (`AV:N/AC:L/Au:S/C:N/I:N/A:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Apr 2008
- **Updated:** 7 Aug 2024
- **Also known as:** GHSA-x337-43mr-gg3h

## What is CVE-2008-1728?

CVE-2008-1728 is a medium-severity denial of service vulnerability in n/a, published on 11 Apr 2008. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

ConnectionManagerImpl.java in Ignite Realtime Openfire 3.4.5 allows remote authenticated users to cause a denial of service (daemon outage) by triggering large outgoing queues without reading messages.

Weakness: CWE-399

## Which versions are affected by CVE-2008-1728?

4 open source packages ship an affected version, including org.igniterealtime.openfire:openfire and org.igniterealtime.openfire:parent. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.igniterealtime.openfire:openfire` | Maven | All versions | 3.5.0 |
| `org.igniterealtime.openfire:openfire` | Maven | All versions | 3.5.0 |
| `org.igniterealtime.openfire:parent` | Maven | All versions | 3.5.0 |
| `org.igniterealtime.openfire:parent` | Maven | All versions | 3.5.0 |

Products: Ignite Realtime Openfire.

## How do I fix CVE-2008-1728?

Upgrade org.igniterealtime.openfire:openfire to 3.5.0 or later.

## Is CVE-2008-1728 being exploited?

There is no known exploitation of CVE-2008-1728 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2007-2975](https://insights.sbomify.com/CVE-2007-2975/): Missing authorization in n/a (high 7.5)
- [CVE-2009-0496](https://insights.sbomify.com/CVE-2009-0496/): Cross-site scripting in n/a (medium 4.3)
- [CVE-2005-4876](https://insights.sbomify.com/CVE-2005-4876/): Cross-site scripting in n/a (medium 4.3)
- [CVE-2005-4877](https://insights.sbomify.com/CVE-2005-4877/): Cross-site scripting in n/a (medium 4.3)
- [CVE-2006-7233](https://insights.sbomify.com/CVE-2006-7233/): Cross-site scripting in n/a (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2008-1728 and fix it if it is affected.

What it is: CVE-2008-1728 is a medium-severity denial of service vulnerability in n/a, published on 11 Apr 2008. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2008-1728 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.igniterealtime.openfire:openfire (Maven): affected all versions; fixed in 3.5.0
- org.igniterealtime.openfire:openfire (Maven): affected all versions; fixed in 3.5.0
- org.igniterealtime.openfire:parent (Maven): affected all versions; fixed in 3.5.0
- org.igniterealtime.openfire:parent (Maven): affected all versions; fixed in 3.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2008-1728/ (Markdown: https://insights.sbomify.com/CVE-2008-1728/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2008-1728
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2008-1728
- OSV: https://osv.dev/vulnerability/CVE-2008-1728

---
From sbomify Insights: https://insights.sbomify.com/CVE-2008-1728/
Summaries are generated and may contain mistakes; the official description above is the record.
