CVE-2008-1937 MoinMoin vulnerable to privilege escalation

Medium 6.8 Published Updated

Remote attackers can gain elevated privileges in MoinMoin Wiki when ACLs or superusers are configured, due to improper user management in form processing.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2008-1937?

CVE-2008-1937 is a medium-severity vulnerability in n/a, published on 24 Apr 2008. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

The user form processing (userform.py) in MoinMoin before 1.6.3, when using ACLs or a non-empty superusers list, does not properly manage users, which allows remote attackers to gain privileges.

Weakness: CWE-264

Which versions are affected by CVE-2008-1937?

3 open source packages ship an affected version, including moin. It affects 1 product.

PackageAffectedFixed in
moin PyPIAll versions1.6.3, 1.7.1
moin PyPIAll versions1.6.3
moin PyPIAll versions1.6.3

Products include Moinmoin Moinmoin.

How do I fix CVE-2008-1937?

Upgrade moin to a fixed version for your release line: 1.6.3 or 1.7.1.

Is CVE-2008-1937 being exploited?

There is no known exploitation of CVE-2008-1937 in the wild and no public exploit code.

Sources

Also known as GHSA-rqxp-6926-hphr, PYSEC-2008-12.

Is CVE-2008-1937 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free