{"answers":{"affected":"3 open source packages ship an affected version, including moin. It affects 1 product.","exploited":"There is no known exploitation of CVE-2008-1937 in the wild and no public exploit code.","fix":"Upgrade moin to a fixed version for your release line: 1.6.3 or 1.7.1.","what":"CVE-2008-1937 is a medium-severity vulnerability in n/a, published on 24 Apr 2008. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2008-1937 and fix it if it is affected.\n\nWhat it is: CVE-2008-1937 is a medium-severity vulnerability in n/a, published on 24 Apr 2008. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2008-1937 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- moin (PyPI): affected all versions; fixed in 1.6.3, 1.7.1\n- moin (PyPI): affected all versions; fixed in 1.6.3\n- moin (PyPI): affected all versions; fixed in 1.6.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2008-1937/ (Markdown: https://insights.sbomify.com/CVE-2008-1937/index.md)","id":"CVE-2008-1937","markdown":"https://insights.sbomify.com/CVE-2008-1937/index.md","name":"CVE-2008-1937","record":{"aliases":["GHSA-rqxp-6926-hphr","PYSEC-2008-12"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["privilege_escalation"],"network_reachable":"yes","non_default_config":true,"product_category":"MoinMoin Wiki","requires_auth":"low_privilege","summary":"Remote attackers can gain elevated privileges in MoinMoin Wiki when ACLs or superusers are configured, due to improper user management in form processing.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"moinmoin","vendor":"moinmoin"}],"cvss":{"score":6.8,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:P/I:P/A:P","version":"2.0"},"cwes":[{"id":"CWE-264","name":null}],"description":"The user form processing (userform.py) in MoinMoin before 1.6.3, when using ACLs or a non-empty superusers list, does not properly manage users, which allows remote attackers to gain privileges.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"MoinMoin vulnerable to privilege escalation","id":"CVE-2008-1937","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"privilege_escalation","year":"2008"},"n_packages":3,"n_references":8,"next":{"headline":"Security feature bypass in n/a","id":"CVE-2008-1938"},"packages":[{"ecosystem":"PyPI","fixed":["1.6.3","1.7.1"],"introduced":["0","1.7"],"last_affected":[],"package":"moin","purl":"pkg:pypi/moin","source":"PYSEC-2008-12"},{"ecosystem":"PyPI","fixed":["1.6.3"],"introduced":["0"],"last_affected":[],"package":"moin","purl":null,"source":"GHSA-rqxp-6926-hphr"},{"ecosystem":"PyPI","fixed":["1.6.3"],"introduced":["0"],"last_affected":[],"package":"moin","purl":"pkg:pypi/moin","source":"GHSA-rqxp-6926-hphr"}],"prev":{"headline":"SQL injection in n/a","id":"CVE-2008-1936"},"products":["n/a"],"published":"2008-04-24","related":[{"cvss_score":10,"headline":"MoinMoin Improper Privilege Management","id":"CVE-2004-1463","kev_date_added":null,"published":"2005-02-13"},{"cvss_score":7.5,"headline":"MoinMoin Improper Access Control","id":"CVE-2004-1462","kev_date_added":null,"published":"2005-02-13"},{"cvss_score":7.5,"headline":"MoinMoin allows administrative access","id":"CVE-2004-0708","kev_date_added":null,"published":"2004-07-21"},{"cvss_score":5.8,"headline":"Cross-site scripting in n/a","id":"CVE-2007-2423","kev_date_added":null,"published":"2007-05-02"},{"cvss_score":5,"headline":"MoinMoin Improper Access Control","id":"CVE-2008-1099","kev_date_added":null,"published":"2008-03-05"},{"cvss_score":5,"headline":"MoinMoin Directory traversal vulnerability","id":"CVE-2008-0782","kev_date_added":null,"published":"2008-02-14"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-07","vendors":["n/a"]},"summary":"Remote attackers can gain elevated privileges in MoinMoin Wiki when ACLs or superusers are configured, due to improper user management in form processing.","url":"https://insights.sbomify.com/CVE-2008-1937/"}