CVE-2008-1947 Apache Tomcat Cross-site scripting (XSS) vulnerability
Remote attackers can inject arbitrary web script via the host-manager add page, requiring high privileges to exploit.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2008-1947?
CVE-2008-1947 is a medium-severity cross-site scripting vulnerability in Apache Tomcat, published on 4 Jun 2008. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Official description
Cross-site scripting (XSS) vulnerability in Apache Tomcat 5.5.9 through 5.5.26 and 6.0.0 through 6.0.16 allows remote attackers to inject arbitrary web script or HTML via the name parameter (aka the hostname attribute) to host-manager/html/add.
Weakness: CWE-79
Which versions are affected by CVE-2008-1947?
8 open source packages ship an affected version, including org.apache.tomcat.embed:tomcat-embed-core and org.apache.tomcat:tomcat. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.apache.tomcat.embed:tomcat-embed-core Maven | From 5.5.9 | 5.5.27 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 5.5.9 | 5.5.27 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 6.0.0 | 6.0.18 |
org.apache.tomcat.embed:tomcat-embed-core Maven | From 6.0.0 | 6.0.18 |
org.apache.tomcat:tomcat Maven | From 5.5.9 | 5.5.27 |
org.apache.tomcat:tomcat Maven | From 5.5.9 | 5.5.27 |
2 more packages
org.apache.tomcat:tomcat Maven | From 6.0.0 | 6.0.18 |
org.apache.tomcat:tomcat Maven | From 6.0.0 | 6.0.18 |
Products include Apache Tomcat.
How do I fix CVE-2008-1947?
Upgrade org.apache.tomcat.embed:tomcat-embed-core to a fixed version for your release line: 5.5.27 or 6.0.18.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2008-1947 being exploited?
There is no known exploitation of CVE-2008-1947 in the wild and no public exploit code.
Other vulnerabilities in Apache Tomcat
Sources
Also known as DSA-1593-1, GHSA-f98p-9pp6-7q6c.