CVE-2008-2302 Django Cross-site scripting (XSS) vulnerability

Medium 4.3 Published Updated

Remote attackers can inject arbitrary web script or HTML into the Django administration login form via a crafted URI, potentially compromising admin sessions.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2008-2302?

CVE-2008-2302 is a medium-severity cross-site scripting vulnerability in n/a, published on 23 May 2008. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Cross-site scripting (XSS) vulnerability in the login form in the administration application in Django 0.91 before 0.91.2, 0.95 before 0.95.3, and 0.96 before 0.96.2 allows remote attackers to inject arbitrary web script or HTML via the URI of a certain previous request.

Weakness: CWE-79

Which versions are affected by CVE-2008-2302?

7 open source packages ship an affected version, including django and Django. It affects 1 product.

PackageAffectedFixed in
django PyPIAll versions1.1
django PyPIFrom 0.910.91.2
django PyPIFrom 0.950.95.3
django PyPIFrom 0.960.96.2
Django PyPIFrom 0.910.91.2
Django PyPIFrom 0.950.95.3
1 more packages
Django PyPIFrom 0.960.96.2

Products include Django Project Django.

How do I fix CVE-2008-2302?

Upgrade django to a fixed version for your release line: 1.1, 0.91.2, 0.95.3 or 0.96.2.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2008-2302 being exploited?

There is no known exploitation of CVE-2008-2302 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2008-2302, GHSA-54qj-48vx-cr9f, PYSEC-2008-1.

Is CVE-2008-2302 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free