{"answers":{"affected":"7 open source packages ship an affected version, including django and Django. It affects 1 product.","exploited":"There is no known exploitation of CVE-2008-2302 in the wild and no public exploit code.","fix":"Upgrade django to a fixed version for your release line: 1.1, 0.91.2, 0.95.3 or 0.96.2.","what":"CVE-2008-2302 is a medium-severity cross-site scripting vulnerability in n/a, published on 23 May 2008. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2008-2302 and fix it if it is affected.\n\nWhat it is: CVE-2008-2302 is a medium-severity cross-site scripting vulnerability in n/a, published on 23 May 2008. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2008-2302 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- django (PyPI): affected all versions; fixed in 1.1\n- django (PyPI): affected from 0.91; fixed in 0.91.2\n- django (PyPI): affected from 0.95; fixed in 0.95.3\n- django (PyPI): affected from 0.96; fixed in 0.96.2\n- Django (PyPI): affected from 0.91; fixed in 0.91.2\n- Django (PyPI): affected from 0.95; fixed in 0.95.3\n- Django (PyPI): affected from 0.96; fixed in 0.96.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2008-2302/ (Markdown: https://insights.sbomify.com/CVE-2008-2302/index.md)","id":"CVE-2008-2302","markdown":"https://insights.sbomify.com/CVE-2008-2302/index.md","name":"CVE-2008-2302","record":{"aliases":["DEBIAN-CVE-2008-2302","GHSA-54qj-48vx-cr9f","PYSEC-2008-1"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Django web framework","requires_auth":"none","summary":"Remote attackers can inject arbitrary web script or HTML into the Django administration login form via a crafted URI, potentially compromising admin sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"django","vendor":"django_project"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"AV:N/AC:M/Au:N/C:N/I:P/A:N","version":"2.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Cross-site scripting (XSS) vulnerability in the login form in the administration application in Django 0.91 before 0.91.2, 0.95 before 0.95.3, and 0.96 before 0.96.2 allows remote attackers to inject arbitrary web script or HTML via the URI of a certain previous request.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Django Cross-site scripting (XSS) vulnerability","id":"CVE-2008-2302","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"xss","year":"2008"},"n_packages":7,"n_references":7,"next":{"headline":"Integer overflow in n/a","id":"CVE-2008-2303"},"packages":[{"ecosystem":"PyPI","fixed":["0.91.2"],"introduced":["0.91"],"last_affected":[],"package":"Django","purl":null,"source":"GHSA-54qj-48vx-cr9f"},{"ecosystem":"PyPI","fixed":["0.95.3"],"introduced":["0.95"],"last_affected":[],"package":"Django","purl":null,"source":"GHSA-54qj-48vx-cr9f"},{"ecosystem":"PyPI","fixed":["0.96.2"],"introduced":["0.96"],"last_affected":[],"package":"Django","purl":null,"source":"GHSA-54qj-48vx-cr9f"},{"ecosystem":"PyPI","fixed":["1.1"],"introduced":["0"],"last_affected":[],"package":"django","purl":"pkg:pypi/django","source":"PYSEC-2008-1"},{"ecosystem":"PyPI","fixed":["0.91.2"],"introduced":["0.91"],"last_affected":[],"package":"django","purl":"pkg:pypi/django","source":"GHSA-54qj-48vx-cr9f"},{"ecosystem":"PyPI","fixed":["0.95.3"],"introduced":["0.95"],"last_affected":[],"package":"django","purl":"pkg:pypi/django","source":"GHSA-54qj-48vx-cr9f"},{"ecosystem":"PyPI","fixed":["0.96.2"],"introduced":["0.96"],"last_affected":[],"package":"django","purl":"pkg:pypi/django","source":"GHSA-54qj-48vx-cr9f"}],"prev":{"headline":"SQL injection in n/a","id":"CVE-2008-2301"},"products":["n/a"],"published":"2008-05-23","related":[{"cvss_score":7.5,"headline":"Django Arbitrary Code Execution","id":"CVE-2007-0404","kev_date_added":null,"published":"2007-01-23"},{"cvss_score":6.8,"headline":"Cross-site request forgery in n/a","id":"CVE-2007-5828","kev_date_added":null,"published":"2007-11-05"},{"cvss_score":6.5,"headline":"Django Improper Access Control","id":"CVE-2007-0405","kev_date_added":null,"published":"2007-01-23"},{"cvss_score":5,"headline":"Django Admin Media Handler Vulnerable to Directory Traversal","id":"CVE-2009-2659","kev_date_added":null,"published":"2009-08-04"},{"cvss_score":2.6,"headline":"Django vulnerable to Denial of Service via i18n middleware component","id":"CVE-2007-5712","kev_date_added":null,"published":"2007-10-30"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-07","vendors":["n/a"]},"summary":"Remote attackers can inject arbitrary web script or HTML into the Django administration login form via a crafted URI, potentially compromising admin sessions.","url":"https://insights.sbomify.com/CVE-2008-2302/"}